Bug Hunting Session
Bug 95560 - Bug in matrix formula
Summary: Bug in matrix formula
Status: CLOSED DUPLICATE of bug 91453
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.7.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-04 08:13 UTC by franco.violi
Modified: 2015-11-04 23:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The attachement containes the replication of the bug (8.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-11-04 08:13 UTC, franco.violi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description franco.violi 2015-11-04 08:13:38 UTC
Created attachment 120252 [details]
The attachement containes the replication of the bug

Using the matrix formula as in attached example it seems that LibreOffice does not honour the "Range include header columns". It worked on previous versions (4.3).
Comment 1 Timur 2015-11-04 11:38:42 UTC
Started in 4.3.7.1, so I add Eike to CC. I don't know if that's related to Bug 42481 but doesn't seem fixed in Bug 91453.
Comment 2 Eike Rathke 2015-11-04 23:32:12 UTC
The sample attempts to calculate with text strings in an array, which by chance worked under some circumstances when all text was expected to be treated as zero. This IS fixed with bug 91453, but you have to specify in Tools->Options->Calc->Formula "Detailed Calculation Settings" * Custom -> Details "Contents to Numbers" "Conversion from text to number" "Treat as zero".

Above all, calculating with text should be avoided.

*** This bug has been marked as a duplicate of bug 91453 ***