Bug Hunting Session
Bug 95624 - FILESAVE: crash when saving
Summary: FILESAVE: crash when saving
Status: RESOLVED DUPLICATE of bug 94936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-05 23:45 UTC by kipk1997
Modified: 2015-11-09 09:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kipk1997 2015-11-05 23:45:30 UTC
When attempting to save a document using "save as" or "save", the program immediately crashes. I have noticed this only on the latest version of Manjaro Linix.
Comment 1 Julien Nabet 2015-11-06 21:41:56 UTC
Which LO version do you use?
If you do this:
- open a terminal
- type export SAL_USE_VCLPLUGIN=gtk
- launch LO from the same terminal and try again
do you reproduce the crash?
Comment 2 kipk1997 2015-11-07 00:25:11 UTC
Using version 5.0.2.2.
When following your steps, it still crashes and this is what I get in the
terminal:

[owner@Laptop ~]$ SAL_USE_VCLPLUGIN=gtk
[owner@Laptop ~]$ libreoffice writer

(soffice:2244): GLib-GObject-WARNING **: gsignal.c:3484: signal name
'selection_changed' is invalid for instance '0x26ff050' of type
'OOoAtkObjCompTxt'

(soffice:2244): Gtk-CRITICAL **: gtk_entry_set_text: assertion
'GTK_IS_ENTRY (entry)' failed

(soffice:2244): Gtk-CRITICAL **: gtk_entry_set_text: assertion
'GTK_IS_ENTRY (entry)' failed

(soffice:2244): Gtk-CRITICAL **: gtk_widget_grab_focus: assertion'GTK_IS_WIDGET (widget)' failed

(soffice:2244): Gtk-CRITICAL **: _gtk_file_chooser_entry_set_base_folder:
assertion 'GTK_IS_FILE_CHOOSER_ENTRY (chooser_entry)' failed

(soffice:2244): Gtk-CRITICAL **: gtk_entry_get_text: assertion
'GTK_IS_ENTRY (entry)' failed

(soffice:2244): Gtk-CRITICAL **: gtk_entry_get_text: assertion
'GTK_IS_ENTRY (entry)' failed
Comment 3 Julien Nabet 2015-11-07 09:16:46 UTC
you must type:
export SAL_USE_VCLPLUGIN=gtk
not just:
SAL_USE_VCLPLUGIN=gtk

without "export", it won't work.

If you still reproduce this, would it be possible you retrieve a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 4 kipk1997 2015-11-08 14:19:02 UTC
When I typed "export SAL_USE_VCLPLUGIN=gtk" then launched it from the terminal, it worked however, it still crashes when launching LibreOffice normally then trying to save. I tried to get a backtrace log But am comfused about step 4. "a gdbtrace.log file will be created in the same folder." What folder is this talking about?
Comment 5 Julien Nabet 2015-11-08 15:52:42 UTC
(In reply to kipk1997 from comment #4)
> When I typed "export SAL_USE_VCLPLUGIN=gtk" then launched it from the
> terminal, it worked however, it still crashes when launching LibreOffice
> normally then trying to save. I tried to get a backtrace log But am comfused
> about step 4. "a gdbtrace.log file will be created in the same folder." What
> folder is this talking about?

The folder from where you launched LO I suppose.

It's possible this problem is already fixed in 5.0.3. Could you give it a try?
Comment 6 Maxim Monastirsky 2015-11-09 09:04:11 UTC

*** This bug has been marked as a duplicate of bug 94936 ***