Bug 95670 - CALCULATING: ForceArray parameters not properly propagated, e.g. for functions expecting scalar values but passed a range reference inside SUMPRODUCT
Summary: CALCULATING: ForceArray parameters not properly propagated, e.g. for function...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.7.1 rc
Hardware: All All
: highest critical
Assignee: Eike Rathke
URL:
Whiteboard: target:5.1.0 target:5.0.4 target:4.4.7
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-11-08 03:35 UTC by m.a.riosv
Modified: 2016-10-25 19:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file SUMPRODUCT bug (20.75 KB, application/vnd.oasis.opendocument.text)
2015-11-08 03:35 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2015-11-08 03:35:39 UTC
Created attachment 120380 [details]
Sample file SUMPRODUCT bug

Attached a basic sample file.

Where LEFT() inside SUMPRODUCT() works only with SUMPRODUCT() forced as array [Ctrl+Enter]

Happens the same with RIGHT(), MID(), T(), N() or DAY().

Seems no function works now inside SUMPRODUCT() without an explicit array.

Seems a very recent regression:
Win10x64

Works with:
Versión: 4.4.6.2 Id. de compilación: 008d5d0ddffba0b82de2a2c36a65b9cba0a6b328
   TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2015-10-14_08:09:18
Version: 5.0.3.2 (x64) Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Version: 5.1.0.0.alpha1 (x64) Build ID: 0b48731919433e46e4fda7e5a5ca27c08c28b981

Fails with:
Version: 4.4.7.0.0+ Build ID: 61a7e6f039294103a1721ec95724d067cf205d0b
  TinderBox: Win-x86@51-TDF, Branch:libreoffice-4-4, Time: 2015-11-03_20:33:02
Version: 5.0.4.0.0+ Build ID: a93c08e8eeb8386d02a015c63d161220d059a6bf-GL
  TinderBox: Win-x86@62-merge-TDF, Branch:lo-5-0, Time: 2015-11-03_16:36:47
Version: 5.1.0.0.alpha1+ (x64) Build ID: 048d47d54d72babe49920ea5e8ff934fe0032125
  TinderBox: Win-x86@42, Branch:master, Time: 2015-10-30_19:51:10
Version: 5.1.0.0.alpha1+ (x64) Build ID: 04783fd91832fa01a5b096f395edd7ad4f9c0f6b
  TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-11-07_21:35:01
Comment 1 Buovjaga 2015-11-11 12:20:35 UTC
How can I recognize a bad result?
For me the files appear identical in versions you define "works" & "fails".

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: 6da681442b17c723f9408a806e8d2367441ad65a
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-07_23:13:46
Locale: fi-FI (fi_FI)
Comment 2 m.a.riosv 2015-11-12 02:50:10 UTC
Doing a hard recalc [Ctrl+F9] result in C5 is #VALUE!
Comment 3 m.a.riosv 2015-11-13 00:28:04 UTC
Present also in:

Version: 4.4.7.1 Buid Id.: ff36774456acc538223589597da53fd987db12e9

changed the version.
Comment 4 Timur 2015-11-13 09:36:44 UTC
Didn't test myself, but confirmed per comments above. 
Since from 4.4.7 probably related to bug 95395 or bug 95419.
Comment 5 Eike Rathke 2015-11-13 12:37:05 UTC
Taking.
Comment 6 Commit Notification 2015-11-16 12:27:37 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=49257e1da7e371fdea0fac080116b0511789cac7

Resolves: tdf#95670 propagate ForceArray per parameter

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-11-16 12:27:41 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=311b5b69f032134457184255920ff1083c9afed2

unit test for tdf#95670

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-11-16 12:47:42 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b31b17e52b2b2b94999d68c4b2ed5c74ee7eed0a

prevent ForceArray propagation on the same token, tdf#95670 follow-up

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Eike Rathke 2015-11-16 15:08:49 UTC
Pending review
https://gerrit.libreoffice.org/19993 for 5-0
https://gerrit.libreoffice.org/19997 for 4-4
https://gerrit.libreoffice.org/19998 for 4-4-7
Comment 10 m.a.riosv 2015-11-17 15:38:36 UTC
Thanks for the quick fix.

Verified:

Version: 5.1.0.0.alpha1+
Build ID: 32d4c03cba399ada807b8ec113a3928aa9e3ff7b
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-16_23:27:02

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 32d4c03cba399ada807b8ec113a3928aa9e3ff7b
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-11-16_23:41:46
Comment 11 steve -_- 2015-11-19 13:16:31 UTC
Unverified as per private request by m.a.riosv, thus back to resolved.

Not sure I agree, since http://bugzilla.readthedocs.org/en/latest/_images/bzLifecycle1.png

also I am confused how LO then uses the Verified state. But he's the original bug reporter so respecting his wish.
Comment 12 Buovjaga 2015-11-19 14:31:20 UTC
(In reply to steve -_- from comment #11)
> Unverified as per private request by m.a.riosv, thus back to resolved.
> 
> Not sure I agree, since
> http://bugzilla.readthedocs.org/en/latest/_images/bzLifecycle1.png
> 
> also I am confused how LO then uses the Verified state. But he's the
> original bug reporter so respecting his wish.

Miguel: please explain yourself. The status of this report should rightly now be VERIFIED.

https://wiki.documentfoundation.org/QA/BugTriage#Step_6._Set_Status

VERIFIED: This option is only available when the current bug status is RESOLVED. You can mark a RESOLVED FIXED bug as VERIFIED, when you can confirm it is fixed with the version mentioned in the bug report. It is also pleasant for the developer who fixed the issue, and is a confirmation the problem is solved now. Otherwise a bug reporter can mark their own bug that is in RESOLVED WORKSFORME state as VERIFIED WORKSFORME to verify it is somehow fixed.
Comment 13 m.a.riosv 2015-11-19 21:31:57 UTC
If I'm not wrong it's pending for revision in versions 4.4 and 5.0. comment#9, and I don't see your verification for those versions. 

I you like VERIFY bugs there are 7568 at this time with the status as RESOLVED FIXED not marked as VERIFIED, a great job for to do.
https://bugs.documentfoundation.org/buglist.cgi?bug_status=RESOLVED&email1=mariosv&emailtype1=substring&list_id=572687&product=LibreOffice&query_format=advanced&resolution=FIXED
Comment 14 Commit Notification 2015-11-20 02:11:26 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=29adff38e8a6e340302c104c4632df9c6551bc38&h=libreoffice-5-0

Resolves: tdf#95670 propagate ForceArray per parameter

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2015-11-20 02:13:06 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ffceb55db60ab2cd5899b2a80583b5fb94bebcf&h=libreoffice-4-4

Resolves: tdf#95670 propagate ForceArray per parameter

It will be available in 4.4.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Adolfo Jayme 2015-11-20 07:35:37 UTC
To be honest, the “verified-versus-resolved” dispute in this bug report is a bit pathetic…
Comment 17 Commit Notification 2015-11-24 15:27:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4-7":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bab5f484e972af91d06cab0da44a40a605bef91d&h=libreoffice-4-4-7

Resolves: tdf#95670 propagate ForceArray per parameter

It will be available in 4.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 m.a.riosv 2016-01-06 13:24:58 UTC
Honest @Adolfo,

Hope you have verified but forgot to inform here.

Verified for 4.4.7 4.4.8 5.0.4

There is an amazing job for you to do, only 566 are CLOSED on a total of 9110 FIXED.