Bug 95672 - VIEWING: Text inside text box appears corrupted when rotated (OpenGL related)
Summary: VIEWING: Text inside text box appears corrupted when rotated (OpenGL related)
Status: RESOLVED DUPLICATE of bug 94917
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-11-08 05:09 UTC by starlitvagabond
Modified: 2015-12-05 17:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
text corruption (52.60 KB, image/png)
2015-11-08 05:09 UTC, starlitvagabond
Details

Note You need to log in before you can comment on or make changes to this bug.
Description starlitvagabond 2015-11-08 05:09:23 UTC
Created attachment 120382 [details]
text corruption

OS Name	Microsoft Windows 10 Pro
Version	10.0.10240 Build 10240
System Manufacturer	Gigabyte Technology Co., Ltd.
System Model	Z97-HD3
System Type	x64-based PC
Processor	Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz, 3501 Mhz, 4 Core(s), 4 Logical Processor(s)
Name	NVIDIA GeForce GTX 970
GPU Driver 358.87 11/4/2015

1) Insert a text box into a document, and type some words into it.
2) Right click the text box -> position options.
3) Rotate it a non-zero # of degrees.
4) Text appears corrupted, like in the attachment.
Comment 1 A (Andy) 2015-11-08 08:02:20 UTC
For me not reproducible with LO 5.0.3.2, Win 8.1

Do you also have this issue if for instance Use Hardware Acceleration or Use OpenGl for all rendering is disabled?
(-> TOOLS -> OPTIONS -> section LIBREOFFICE -> subsection VIEW)
Comment 2 starlitvagabond 2015-11-08 15:39:17 UTC
"Use Hardware Acceleration" was ghosted.  However, disabling "Use OpenGL for all rendering" fixed the corruption.  Thanks!

I'm using the latest NVIDIA drivers on a modern-generation GPU, so their OpenGL support should be up-to-date.  Odd.
Comment 3 A (Andy) 2015-11-08 17:55:47 UTC
Nice to hear that I could help you.

There seemed to be some problems with the hardware acceleration, but also with the OpenGl rendering, in the latest release of LO under Win 10.

Unfortunately, I have only Win 8.1.  That's why I could not confirm this bug.
I will keep this bug open as unconfirmed, that anybody else can maybe confirm it.
Comment 4 raal 2015-11-12 16:55:45 UTC
Please attach test file.
Comment 5 m.a.riosv 2015-12-05 02:05:03 UTC
Happens also with Calc, Impress and Draw,

with OpenGL enable.

Calc, write a text in a cell and apply "Heading1" style.
Draw, insert any text and rotate the box.
Comment 6 Maxim Monastirsky 2015-12-05 17:23:57 UTC

*** This bug has been marked as a duplicate of bug 94917 ***