Download it now!
Bug 95708 - preserve case in find&replace
Summary: preserve case in find&replace
Status: RESOLVED DUPLICATE of bug 38261
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-09 17:04 UTC by Manuel Lopez-Ibanez
Modified: 2015-11-10 11:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Lopez-Ibanez 2015-11-09 17:04:44 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:42.0) Gecko/20100101 Firefox/42.0
Build Identifier: LibreOffice 4.2.8.2

When replacing "word" by "text" without "Match case" both word and Word will be replaced by "text". However, I would expect that "word" is replaced by "text" and "Word" by "Text" (and "WORD" by "TEXT").

Reproducible: Always




[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: no


Reset User Profile?No
Comment 1 V Stuart Foote 2015-11-09 23:40:23 UTC
Why would you *expect* that?  The match is the found text--not the replaced text.

If you need more granularity--run more finds/replaces

If you're suggesting this as an enhancement--that is a bucket load of work for a very corner case.  Wontfix.
Comment 2 Timur 2015-11-10 11:36:55 UTC
I won't reopen but I don't agree with WontFix. 
That's "Preserve capitalization" option from Alternative Find & Replace extension.
Comment 3 Manuel Lopez-Ibanez 2015-11-10 11:51:35 UTC
(In reply to Timur from comment #2)
> I won't reopen but I don't agree with WontFix. 
> That's "Preserve capitalization" option from Alternative Find & Replace
> extension.

Thanks for the pointer. Another pointer is that Emacs and Eclipse can do this. Of course, I understand that it may be too much work for little benefit. I also understand that if it were truly important for LO users, somebody (or me) would have already implemented it.

The corresponding AOO bug is https://bz.apache.org/ooo/show_bug.cgi?id=17188

I'd prefer to close this as a duplicate of bug 38261 (although a regex solution for this seems overkill to me, but I'll be happy with what I can get), to keep track of the interest on this and the potential pool of developers, testers, backers of this feature.

*** This bug has been marked as a duplicate of bug 38261 ***