Bug Hunting Session
Bug 95713 - FORMATTING: Underline position/thickness varies for different font sizes on same line.
Summary: FORMATTING: Underline position/thickness varies for different font sizes on s...
Status: RESOLVED DUPLICATE of bug 68573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-09 23:17 UTC by Sascha Fichtner
Modified: 2015-11-10 00:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Simple example .odt incl. underlined text of different sizes on the same line. (9.23 KB, application/vnd.oasis.opendocument.text)
2015-11-09 23:17 UTC, Sascha Fichtner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Fichtner 2015-11-09 23:17:06 UTC
Created attachment 120429 [details]
Simple example .odt incl. underlined text of different sizes on the same line.

Problem description:
Underlining a range of text on the same line that uses different font sizes 
causes the underline to be at different vertical positions and of different 
thickness. This might be related to Bug 68573.

Steps to reproduce:
Load the attached .odt file.
Alternatively write a few words on one line, use different font sizes for 
different parts of the text, then underline the whole line.

Current behavior:
The 'underline' will visually differ depending on the used font size. 
Reproduceable in LibreOffice 5.0.3.2

Expected behavior:
The 'underline' should be contiguous (same vertical position and thickness) 
across the whole range (as long as that range of text is on the same line). 
Microsoft Office 2016 does it that way, Office 2013 probably as well (couldn't
verify myself, though).
Comment 1 V Stuart Foote 2015-11-10 00:04:37 UTC
Not just related to bug 68573, rather it is the same issue. We don't make use of the font metrics.

If you need consistent underline-- select the text and use the Character dialog to apply a bottom border. Unfortunately the best you can do is touch the descenders of the fonts--would be nice if we could actually set spacing to contents negative to truly position underline.

*** This bug has been marked as a duplicate of bug 68573 ***