Bug 95752 - FORMATTING: Styles are removed when an RTF document is exported to ODT and the Clear Direct Formatting option is used
Summary: FORMATTING: Styles are removed when an RTF document is exported to ODT and th...
Status: RESOLVED DUPLICATE of bug 47471
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-11 20:30 UTC by yaffia
Modified: 2019-01-03 10:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test document (5.32 KB, application/rtf)
2015-11-11 20:30 UTC, yaffia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yaffia 2015-11-11 20:30:48 UTC
Created attachment 120484 [details]
Test document

This issue can be easily reproduced using the following steps:
1. Create a new document, apply some styles there (I used Heading1 and Heading2), and save it as RTF. Just in case, I have attached my test document.
2. Close the document.
3. Open it again and save as ODT.
4. Press Clear Direct Formatting and save the document.
That's all. Next time you open the document styles (in my case, Heading1 and Heading2) are not applied anymore.

I am using version 5.0.3.2 on Arch Linux
Comment 1 Buovjaga 2015-11-15 15:37:50 UTC
Seems to be a duplicate.
But the test file is nice to have.

*** This bug has been marked as a duplicate of bug 47471 ***
Comment 2 Timur 2019-01-03 10:23:13 UTC
Verified duplicate.