Download it now!
Bug 95774 - Tools -> Macros -> Run Macro... Causes Immediate Crash
Summary: Tools -> Macros -> Run Macro... Causes Immediate Crash
Status: RESOLVED DUPLICATE of bug 94716
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-12 15:41 UTC by Iandol
Modified: 2015-11-14 04:49 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
screenshot (107.82 KB, image/png)
2015-11-12 15:41 UTC, Iandol
Details
screenshot (64.39 KB, image/png)
2015-11-12 15:43 UTC, Iandol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iandol 2015-11-12 15:41:13 UTC
Created attachment 120505 [details]
screenshot

On OS X 10.11 WITHOUT Java6 installed (which is the OS default, and Java is very deprecated on OS X). Clicking Tools -> Macros -> Run Macro... and LibreOffice immediately crashes and a Please install Java dialog appears. On restart the recovery dialog appears. 

LO should try to remove the dependency on Java 6, irrespective of the fact it should not crash LO when not present.
Comment 1 Iandol 2015-11-12 15:43:27 UTC
Created attachment 120506 [details]
screenshot

This is my Options > Advanced. I do have Java 8 installed and being "used" by LO.
Comment 2 Alex Thurgood 2015-11-13 15:21:48 UTC
It might help if you told us which macro you are trying to run.


Additionally, and at present, a fix has been suggested to avoid the requirement for Java6 in master 5.1, however, it comes with its own problems, see bug 94716.

Versions 5.0.x and lower still require Java6 for OSX, plus any additional Oracle JDK that a user might install. Again, this is already known.

These are known issues. Setting as DUP of 94716.

*** This bug has been marked as a duplicate of bug 94716 ***
Comment 3 Iandol 2015-11-14 04:49:58 UTC
Thanks Alex, this bug triggers when using the menu itself, you never get to ever run a macro. Will test 5.1 nightly...