Bug 95820 - LAYOUT: Mixing RTL and numbers causes spaces to be layed out incorrectly
Summary: LAYOUT: Mixing RTL and numbers causes spaces to be layed out incorrectly
Status: RESOLVED DUPLICATE of bug 89034
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-14 13:59 UTC by Herouth Maoz
Modified: 2015-11-16 10:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Plain text demonstrating the issue (22 bytes, text/plain)
2015-11-14 13:59 UTC, Herouth Maoz
Details
Screenshot of (bad) layout in Libreoffice (18.41 KB, image/png)
2015-11-14 14:01 UTC, Herouth Maoz
Details
screenshot of (good) layout in NeoOffice (12.69 KB, image/png)
2015-11-14 14:02 UTC, Herouth Maoz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Herouth Maoz 2015-11-14 13:59:49 UTC
Created attachment 120538 [details]
Plain text demonstrating the issue

Text in Hebrew which contains numbers as well shifts spaces around. For example, the attached text file, when set to right-to-left paragraph direction, displays a space at the beginning of the line, and no spaces before the numbers.

Note: the attached file is not an ODT file, it's a plain text file in UTF-8, so there can be no mistake about its content or hidden formatting: A word in Hebrew, followed by space, number, space, word in hebrew, space, number, newline.

So when you open the file, please simply click on the right-to-left paragraph direction button to see the layout problem.

Note: NeoOffice does not have the problem, OpenOffice does, though.

This problem is Mac only.

Operating system is MacOS Yosemite, the same problem occurs in El-Capitan.

I tried changing the font using Apple-originating fonts, Culmus fonts, Microsoft-originating fonts. Nothing seems to work.
Comment 1 Herouth Maoz 2015-11-14 14:01:31 UTC
Created attachment 120539 [details]
Screenshot of (bad) layout in Libreoffice
Comment 2 Herouth Maoz 2015-11-14 14:02:28 UTC
Created attachment 120540 [details]
screenshot of (good) layout in NeoOffice
Comment 3 A (Andy) 2015-11-14 23:01:05 UTC
I have an even more basic problem with LO 5.0.3.2, Win 8.1.  The Hebrew characters are not shown at all.  I have only cryptic characters.
Comment 4 Buovjaga 2015-11-15 18:18:02 UTC
Same result as Andy, if I save the .txt file and open.
But if I copy & paste the text and set to RTL, it is ok like in the NeoOffice screenshot.
Thus seems to be Mac-only indeed.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)
Comment 5 Alex Thurgood 2015-11-16 10:19:55 UTC

*** This bug has been marked as a duplicate of bug 89034 ***
Comment 6 Herouth Maoz 2015-11-16 10:57:49 UTC
@Alex Thurgood: are you sure this is a duplicate of that bug? The problem here is not related to justification, and bug 89034 seems to be about wrong spacing for fully justified text. Also, that bug doesn't seem to involve numbers at all, whereas this bug shows when there are numbers in the Hebrew line.

(In reply to Alex Thurgood from comment #5)
> 
> *** This bug has been marked as a duplicate of bug 89034 ***