Download it now!
Bug 95855 - Images meshed up, stretched or missing when exporting pdf
Summary: Images meshed up, stretched or missing when exporting pdf
Status: RESOLVED DUPLICATE of bug 94739
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-16 12:35 UTC by Carlo
Modified: 2015-11-17 17:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test files (29.88 KB, application/x-7z-compressed)
2015-11-16 12:35 UTC, Carlo
Details
test with openGL disabled (24.88 KB, application/x-7z-compressed)
2015-11-17 17:51 UTC, Carlo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo 2015-11-16 12:35:25 UTC
Created attachment 120577 [details]
test files

Hi all,

I'm using LO 5.0.3.2 on Windows 10. When exporting an odt to pdf all images are stretched, or grayscaled, or messed up. If i print the file with pdfcreator the images disappear.

The same problem does not appear in LO 4.4.0.3, using the same file (thus the problem seems to be related to LO 5 pdf export library).

With lossless compression jpg images are stretched. Using jpg compression jpg image is ok. Problems occur in any case with png files.

Attached a sample odp pdf prints and image files. The first image is a jpg, correctly displayed. The second one is the same logo but png file format.

Any idea?

Thank you,

Carlo
Comment 1 Buovjaga 2015-11-16 18:19:18 UTC
What if you disable Tools - Options - LibO - View - Use OpenGL for all rendering

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED DUPLICATE of 94739, if the problem went away.
Comment 2 Carlo 2015-11-17 15:49:43 UTC
(In reply to Beluga from comment #1)
> What if you disable Tools - Options - LibO - View - Use OpenGL for all
> rendering

Nothing changes. It seems to be different from bug 94739.

Changed status to UNCONFIRMED.
Comment 3 Buovjaga 2015-11-17 16:03:30 UTC
(In reply to Carlo from comment #2)
> (In reply to Beluga from comment #1)
> > What if you disable Tools - Options - LibO - View - Use OpenGL for all
> > rendering
> 
> Nothing changes. It seems to be different from bug 94739.
> 
> Changed status to UNCONFIRMED.

Just to confirm: did you restart LibreOffice after disabling the setting?
Comment 4 Carlo 2015-11-17 17:51:40 UTC
Created attachment 120601 [details]
test with openGL disabled
Comment 5 Carlo 2015-11-17 17:53:12 UTC
Thank you Beluga, restarting LO the prints are perfect, both with lossless or jpeg compression.

Bye,

Carlo

*** This bug has been marked as a duplicate of bug 94739 ***