Bug 95915 - Windows 8.1 and 10 using system Segoe UI rather than OpenSymbol for displaying some Operators
Summary: Windows 8.1 and 10 using system Segoe UI rather than OpenSymbol for displayin...
Status: RESOLVED DUPLICATE of bug 60268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-18 20:15 UTC by V Stuart Foote
Modified: 2016-10-31 23:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample formula with incorrect Segoe glyps used for operators (13.07 KB, image/jpeg)
2015-11-18 20:32 UTC, V Stuart Foote
Details
screen clip of test formula in 4.3.7 on Windows 8.1 (16.95 KB, image/jpeg)
2015-11-18 20:43 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-11-18 20:15:07 UTC
In a weird MS gotcha, seems that Windows 8.1 and 10 have somehow been substituting Segoe UI in Math formula editor when the formula Operator's "prod", "sum" and "int" are used.

Windows 7 sp1 installs are not affected.

Weird in that "coprod" and "lint" are unaffected, as are the "iint" and "iiint" and variants of "lint".
Comment 1 V Stuart Foote 2015-11-18 20:32:25 UTC
Created attachment 120632 [details]
sample formula with incorrect Segoe glyps used for operators

STR

Enter this as an example formula in Math on a Windows 8.1 or Windows 10 install.

"prod %PI sum %SIGMA int iint coprod a"

the %PI and %SIGMA render correctly in OpenSymbol, as do iint and coprod.

Screen clip attached.
Comment 2 V Stuart Foote 2015-11-18 20:43:37 UTC
Created attachment 120633 [details]
screen clip of test formula in 4.3.7 on Windows 8.1

Looking at an /a install of 4.3.7.2 run on Windows 8.1, in addition to "prod" and "int", "coprod" and the "lint" are rendered in Segoe UI system font--but strangely the "sum" operator picks up OpenSymbol.

clip attached.
Comment 3 V Stuart Foote 2015-11-18 21:00:56 UTC
(In reply to V Stuart Foote from comment #2)
> font--but strangely the "sum" operator picks up OpenSymbol.
> 
> clip attached.

Actually the capital SIGMA there is not from OpenSymbol different weights on the leg and the serif--reviewing in BableMap--it looks like it and all of these symbols are from MS "Seoge UI Symbol" font.  

That I guess would make more sense but is it the behavior we want?
Comment 4 V Stuart Foote 2015-11-18 21:10:33 UTC
Looking at BableMap--the Segoe Symbol UI being used is pulling from the Mathematical Operators page at Ux2200. We get Ux220F for N-ARY PRODUCT, and Ux2211 for N-ARY SUMMATION.

OpenSymbol has the same page defined--so not clear why Windows 8.1 and Windows 10 are using Segoe Symbol UI instead of OpenSymbol which is present on the system(s).
Comment 5 V Stuart Foote 2015-11-20 16:14:33 UTC
Until this can be corrected, as this affects Windows users only, a reasonable work around is to perform a LibreOffice font substitution (Tools -> Options -> Fonts): replacing OpenSymbol with Cambria Math -- a font present on all MS Windows releases since MS Vista.

@Andras, noticed in bug 76239 (though that OpenSymbol install issue is not related to this at all) that you're working in Windows 8.1--any thoughts here about OS' Segoe UI font selection and non-use of OpenSymbol for specific dialogs?
Comment 6 V Stuart Foote 2015-11-20 17:00:25 UTC
Spent more time in the font charts using BableMap -- so the only symbols being assigned from Segoe UI rather than OpenSymbol are where the font glyph actually exists in Segoe UI (v 5.53 on Windows 10). Unfortunately that is not a full set of glyphs for the Mathematical Operators Unicode block. Those are defined in Segoe UI Symbol, but those are not pulled.

Result in LibreOffice (and AOO) is a mix of OpenSymbol and Segoe UI in formula, unless a font replacement is specified for OpenSymbol, which itself is weird.

Leading to the development question "Why are MS Windows 8, 8.1 and 10 substituting the system front for our OpenSymbol usage?" and "How do we prevent it?".
Comment 7 Buovjaga 2015-12-04 17:16:37 UTC
My result matches attachment 120632 [details]

Win 8.1 32-bit
Version: 5.2.0.0.alpha0+
Build ID: 51a5dfd783bfc1efc52a791aab4114039581252f
Threads 4; Ver: Windows 6.2; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-04_10:49:33
Locale: fi-FI (fi_FI)
Comment 8 V Stuart Foote 2016-10-31 23:10:24 UTC

*** This bug has been marked as a duplicate of bug 60268 ***