Bug Hunting Session
Bug 95962 - crash: gtk3 New macro
Summary: crash: gtk3 New macro
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.1.0
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-11-20 23:22 UTC by Julien Nabet
Modified: 2016-10-25 19:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (20.43 KB, text/plain)
2015-11-20 23:22 UTC, Julien Nabet
Details
valgrind log (105.67 KB, text/x-log)
2015-11-20 23:34 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2015-11-20 23:22:13 UTC
Created attachment 120689 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I had a crash when doing these steps:
1) Launch Writer
2) Select Tools Menu, then Macros
3) Select Organize Macros then Basic
4) Select in left panel "Untitle 1"
5) Click "New" button then leave by default name, then click "Ok" button
=> crash

I reproduce this with gtk3 not gtk (switch with env var "SAL_USE_VCLPLUGIN")

Remark: if I use gtk first (and so don't reproduce the crash) then use gtk3, I don't reproduce it. I must remove first my LO directory profile to reproduce this again with gtk3
Comment 1 Julien Nabet 2015-11-20 23:34:58 UTC
Created attachment 120690 [details]
valgrind log
Comment 2 Julien Nabet 2015-11-20 23:45:48 UTC
Caolan: thought you might be interested in this one since it concerns vcl part + gtk3 specifically.
(I attached bt with debug + Valgrind with an invalid read in ColorMask::GetColorFor32Bit)
Comment 3 Commit Notification 2015-11-24 18:51:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9b52b8999be86e5c6e5f5901b2640b16f08a2323

Resolves: tdf#95962 incorrect scanline stride

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2015-11-25 19:13:24 UTC
I've updated my local repo and indeed it works now.

Thank you Caolan! :-)