Download it now!
Bug 95986 - IMPORT DOC: wrong image rotation and flip
Summary: IMPORT DOC: wrong image rotation and flip
Status: RESOLVED DUPLICATE of bug 56321
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks:
 
Reported: 2015-11-22 13:48 UTC by V Stuart Foote
Modified: 2015-12-17 06:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
attachement 120702 as converted to DOC (139.50 KB, application/msword)
2015-11-22 13:48 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-11-22 13:48:35 UTC
Created attachment 120720 [details]
attachement 120702 as converted to DOC

Split from bug 95970 which is specific to import of OOXML with rotated/flipped images, this is for same issues but in the MS DOC binary ww8 import filter. 

Attached Microsoft Word 97-2003 format DOC with image is rotated by ~13° and flipped (it has OOXML tag a:xfrm with attributes rot="776457" and flipH="1").

The lion should look left and slightly upwards. On import, it's upside down and looks left. It has rotation 167.06°, and if set to 13°, it turns right.
Comment 1 V Stuart Foote 2015-11-22 13:55:51 UTC
(In reply to V Stuart Foote from comment #0)

> The lion should look left and slightly upwards. On import, it's upside down
> and looks left. It has rotation 167.06°, and if set to 13°, it turns right.

What I get for copy-n-paste of original-- here, on filter import the image is not flipped and not rotated at all by the ww8 filter.
Comment 2 Buovjaga 2015-12-01 12:53:36 UTC
Related to / same as bug 56321?
Comment 3 V Stuart Foote 2015-12-01 13:50:15 UTC
(In reply to Beluga from comment #2)
> Related to / same as bug 56321?

Probably.  Of course this is for handling flip and rotation on *import* of a MS Office binary document. tdf#56321 was for round trip ww8 export -> ww8 import. And IIRC we didn't yet have ability for rotation of images in Writer at that point.

*** This bug has been marked as a duplicate of bug 53621 ***
Comment 4 V Stuart Foote 2015-12-01 13:50:57 UTC
s/ bug 53621 / bug 56321

*** This bug has been marked as a duplicate of bug 56321 ***
Comment 5 Robinson Tryon (qubit) 2015-12-17 06:38:40 UTC
Migrating Whiteboard tags to Keywords: (filter:doc)
[NinjaEdit]