Bug 95991 - LibO crashes when watching and inspecting a complex Calc structure in BASIC debug session
Summary: LibO crashes when watching and inspecting a complex Calc structure in BASIC d...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2015-11-22 18:59 UTC by Wolfgang Jäger
Modified: 2016-01-19 12:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Extremely simplified Calc file for reproducing the crash (9.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-11-22 18:59 UTC, Wolfgang Jäger
Details
Backtrace of crash on Windows, LibO 5.0.3 (13.22 KB, text/plain)
2015-11-28 18:03 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Jäger 2015-11-22 18:59:07 UTC
Created attachment 120724 [details]
Extremely simplified Calc file for reproducing the crash

(Most simple case)

The only module in the Standard container for BASIC code of a Calc document is containing only the Sub TestWatch() with the followig code:

Sub TestWatch()
oCell = ThisComponent.Sheets(0).GetCellByPosition(0,0)
MsgBox oCell.Value
End Sub

1. Open BASIC editor
2. Stepwise execute the Sub --> Works as expected
3. Add oCell to the Watch list (as the only element) 
4. Stepwise execute the Sub without touching the watched structure --> Works
5. Step into Sub till oCell is assigned but do not finish execution
6. Try to expand oCell in the Watch window --> Complete crash.

The crash also happens if another complex structure should be inspected, independent of whether debugging a Sub or a Function, 
independent of whether code is contained in the document or local,
independent of how many variables are watched
...

Just tested with V5.0.3 but already present in V5.0.1
Comment 1 Wolfgang Jäger 2015-11-22 21:18:18 UTC
Additional remarks

1. The describd crash is also reproducible with a virgin user profile (except having set macro security to 'Medium'.

2. The original (first) attachment here opened with either
LibreOffice V4.4.5.(release)Portable  or with 
Apache OpenOffice V4.1.2 Portable 
and the described steps performed does not cause any problems the oCell structure can fully be inspected.
Comment 2 raal 2015-11-24 09:42:00 UTC
No crash with Version: 5.1.0.0.alpha1+ and 5.0.2.2, win7
Comment 3 Buovjaga 2015-11-28 18:03:50 UTC
Created attachment 120854 [details]
Backtrace of crash on Windows, LibO 5.0.3

Repro.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)
Comment 4 Wolfgang Jäger 2015-11-28 19:00:27 UTC
(In reply to raal from comment #2)
> No crash with Version: 5.1.0.0.alpha1+ and 5.0.2.2, win7

I did not test with the alpha version, but:

Using V5.1.0.0beta1 (x64) (Win 8.1) the crash occurs under unchanged condition strictly reproducible.
Comment 5 Wolfgang Jäger 2016-01-19 11:38:29 UTC
Works for me now in V 5.1.0.2 (x64, Win 8.1).
Suppose the bug is fixed now.
Comment 6 raal 2016-01-19 12:22:54 UTC
closinf the bug.