Bug 95993 - Presentation saved as PPTX doesn't show text in outline mode (after reopening)
Summary: Presentation saved as PPTX doesn't show text in outline mode (after reopening)
Status: RESOLVED DUPLICATE of bug 77552
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6 all versions
Hardware: x86 (IA32) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-22 20:09 UTC by T Dymond
Modified: 2021-04-15 06:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description T Dymond 2015-11-22 20:09:24 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/45.0.2454.101 Chrome/45.0.2454.101 Safari/537.36
Build Identifier: LibreOffice 4.4.6.3

In xubuntu, started creating a presentation in outline view; text did show in slides. After saving & closing as a pptx, then re-opening, text still showed in slides, but although outline view showed slides existed, no text was displayed.

Reproducible: Always

Steps to Reproduce:
1. Start new presentation in outline view.
2. Save & close presentation as pptx.
3. Reopen presentation, change to outline view.
Actual Results:  
Slides on left hand sidebar showed previous text; outline view recognised the number of slides, but showed no text.

Expected Results:  
Show text in outline view, to allow further changes.

[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: no


Reset User Profile?No
Comment 1 Cor Nouws 2015-11-23 09:50:32 UTC
Thanks for filing, trevdymond.

I confirm the problem in a daily build from 2015-11-17.

Cheers - Cor
Comment 2 Cor Nouws 2015-11-23 09:54:36 UTC
Already the case in 3.6.6.
So this probably never has worked?
Comment 3 T Dymond 2015-12-06 08:52:17 UTC
1 I've recently upgraded to LibreOffice 5.0.2.2, so this applies in future.

2 I opened a pptx file, created in PowerPoint, in Impress, & when I switched to Outline view, the slide text appeared in the view. However, if I saved the file in Impress & reopened it, no text showed in the Outline view.

This suggests to me that PowerPoint, in a pptx file, saves a slide version of the text AND an Outline version of the text, and Impress is either actively removing the Outline version, or doesn't recognise and save that text buffer.
Comment 4 Timur 2017-05-03 10:49:39 UTC
Looks like a duplicate of Bug 77552. For the sake of efficiency, I'll mark so. 
Please monitor that bug and test when it's hopefully resolved. 
If you disagree, please explain and set again to New.

*** This bug has been marked as a duplicate of bug 77552 ***