Bug Hunting Session
Bug 96027 - As apparently picked up from the StartCenter startMoudle settings, minimum window height across all components is incorrectly set to a fixed value, too tall for some users
Summary: As apparently picked up from the StartCenter startMoudle settings, minimum wi...
Status: RESOLVED DUPLICATE of bug 93085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2015-11-24 05:49 UTC by andréb
Modified: 2015-11-24 14:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andréb 2015-11-24 05:49:52 UTC
In Libo 4.4.6.3 there was no apparent minimum window height (4 cm was possible).
In Libo 5.0.3.2 there is a minimum window height of 14.5 cm.

In order to (easily) use Libo with other applications (my normal usage), I need a window height of 10 cm or less.

The use case for imposing a minimum window height is unclear.
If a user doesn't want a smaller window, they don't have to make it smaller.  However if a user does want/need a smaller window, a minimum size (especially almost full screen height) is dysfunctional.
Comment 1 Cor Nouws 2015-11-24 09:19:19 UTC
Hi André,

I confirm this in daily build 2015-11-23
It's not only for Calc, but all applications, so set component to LibreOffice.
Thanks,
Cor
Comment 2 V Stuart Foote 2015-11-24 14:41:58 UTC
Seems linked to the minimum height size for the StartCenter is "bleeding" over to the other modules.

Suspect this is the case, as between 5.0.3.2 and current master we have added the Remote Files feature and the minimum window height for all components was bumped taller.

The behavior of the StartCenter
Comment 3 V Stuart Foote 2015-11-24 14:46:49 UTC
(In reply to V Stuart Foote from comment #2)
> Seems linked to the minimum height size for the StartCenter is "bleeding"
> over to the other modules.
> 
> Suspect this is the case, as between 5.0.3.2 and current master we have
> added the Remote Files feature and the minimum window height for all
> components was bumped taller.
> 
> The behavior of the StartCenter

... affects each component being launched from it, setting a minimum height for that launch.

The same component launched without use of the the StartCenter is not affected and its UI can be fully resized in height.
Comment 4 Maxim Monastirsky 2015-11-24 14:56:25 UTC
Basically the same problem as in Bug 93085.

*** This bug has been marked as a duplicate of bug 93085 ***