Bug 96059 - Cleanup: Replace imageproducer with CommandInfoProvider
Summary: Cleanup: Replace imageproducer with CommandInfoProvider
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Susobhan Ghosh
URL:
Whiteboard: target:5.1.0 target:5.2.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
Depends on:
Blocks:
 
Reported: 2015-11-25 11:16 UTC by Samuel Mehrbrodt (CIB)
Modified: 2016-10-25 19:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2015-11-25 11:16:45 UTC
git grep imageproducer

Then replace all occurrences of GetImageFromURL(...) with vcl::CommandInfoProvider::Instance().GetImageForCommand(...).

Example commit will follow shortly.
Comment 1 Commit Notification 2015-11-25 12:56:37 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02044b5d2711e837cfc8680a265614e138e79d86

tdf#96059 Replace imageproducer with CommandInfoProvider

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Joel Madero 2015-12-05 07:21:22 UTC
Can this be set to fixed?
Comment 3 Samuel Mehrbrodt (CIB) 2015-12-05 11:07:15 UTC
No, comment 1 was only an example commit. There are lots of other places where this needs to be done.
Comment 4 Robinson Tryon (qubit) 2015-12-14 07:06:57 UTC Comment hidden (obsolete)
Comment 5 Susobhan Ghosh 2016-01-03 07:49:33 UTC
Hi! This is my first bug fix. I'm a new contributor. I've successfully build LO, and tried git grep imageproducer.

I've doubts regarding this specific GetImageFromURL call in http://opengrok.libreoffice.org/xref/core/framework/source/classes/menumanager.cxx#232

How do I change this to the specified function call? There are two parameters given. The example commit doesn't help with that.
Comment 6 Susobhan Ghosh 2016-01-03 08:10:42 UTC
(In reply to Susobhan Ghosh from comment #5)
> Hi! This is my first bug fix. I'm a new contributor. I've successfully build
> LO, and tried git grep imageproducer.
> 
> I've doubts regarding this specific GetImageFromURL call in
> http://opengrok.libreoffice.org/xref/core/framework/source/classes/
> menumanager.cxx#232
> 
> How do I change this to the specified function call? There are two
> parameters given. The example commit doesn't help with that.

Never mind. I got it. Will be pushing changes soon.
Comment 7 Susobhan Ghosh 2016-01-03 08:15:31 UTC
I'm assigning this to myself.
Comment 8 Commit Notification 2016-01-05 09:53:51 UTC
susobhang70 committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5c39b28a87060f80404079ab77604f664addb063

tdf#96059 Replaced imageproducer with CommandInfoProvider

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Maxim Monastirsky 2016-01-13 15:38:52 UTC
(In reply to Commit Notification from comment #8)
> susobhang70 committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=5c39b28a87060f80404079ab77604f664addb063
> 
> tdf#96059 Replaced imageproducer with CommandInfoProvider
> 
This commit created a regression in the File->New menu, because the entries there aren't .uno command. This particular case should be changed to SvFileInformationManager::GetImageNoDefault, instead of CommandInfoProvider.
Comment 10 Commit Notification 2016-01-15 08:13:49 UTC
Susobhan Ghosh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51b71a7be13611acc02a702cf025425fc746f4a2

Related tdf#96059 Fix icons in File->New menu

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Robinson Tryon (qubit) 2016-02-18 16:37:32 UTC Comment hidden (obsolete)