Bug Hunting Session
Bug 96117 - FILEOPEN, FILESAVE: cross-references to user-defined numbered items are corrupted by saving and reloading in .doc or .docx format
Summary: FILEOPEN, FILESAVE: cross-references to user-defined numbered items are corru...
Status: RESOLVED DUPLICATE of bug 42346
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-28 16:42 UTC by Rolf Bartstra
Modified: 2015-12-03 15:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Corrupt cross-reference to user-defined numbered item in .doc(x) format (12.00 KB, application/msword)
2015-11-28 16:42 UTC, Rolf Bartstra
Details
.odt document with cross-references that get corrupt when saved as .doc (x) (11.41 KB, application/vnd.oasis.opendocument.text)
2015-12-03 09:50 UTC, Rolf Bartstra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Bartstra 2015-11-28 16:42:16 UTC
Created attachment 120852 [details]
Corrupt cross-reference to user-defined numbered item in .doc(x) format

Cross-references to user-defined numbered items are corrupted after saving and reloading the document in .doc or .docx format:

When saved as .doc:
- the cross-reference is replaced by the corresponding hard-coded number
- the font of the target is replaced by a default font;

When saved as .docx:
- the cross-reference is replaced by the (hard-coded) name of the type of the target, while the referenced number disappears altogether.
Comment 1 Buovjaga 2015-11-30 10:09:52 UTC
Could you attach an example .odt so we can quickly test?

The problem looks a bit like bug 90488, but the result is different..

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 Rolf Bartstra 2015-12-03 09:50:09 UTC
Created attachment 120985 [details]
.odt document with cross-references that get corrupt when saved as .doc (x)
Comment 3 Timur 2015-12-03 13:03:31 UTC
A duplicated of Bug 42346 - FILESAVE: Cross-references to certain numbered items (object, graphic, table) turn to plain text on export to .doc or .docx ?
Comment 4 Rolf Bartstra 2015-12-03 15:39:59 UTC
(In reply to Timur from comment #3)
> A duplicated of Bug 42346 - FILESAVE: Cross-references to certain numbered
> items (object, graphic, table) turn to plain text on export to .doc or .docx
> ?

Yes, seems to be the same bug, I 'll mark mine as duplicate.

*** This bug has been marked as a duplicate of bug 42346 ***