Bug 96133 - Enabling OpenGL in the UI doesn't notify/warn/inform the user that LibO needs to be restarted
Summary: Enabling OpenGL in the UI doesn't notify/warn/inform the user that LibO needs...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: Impress-OpenGL
  Show dependency treegraph
 
Reported: 2015-11-29 13:52 UTC by Cor Nouws
Modified: 2015-12-18 10:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibO 5.1.x screenshot (32.66 KB, image/png)
2015-11-29 18:02 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2015-11-29 13:52:48 UTC
Change Tools > LibreOffice > Language Settings > Language .. interface and it tells you that you need to restart LibreOffice.

Change Tools > Options > LibreOffice > View .. use OpenGL for all rendering
and you won't get a hint...

It should :)
Comment 1 Cor Nouws 2015-11-29 13:53:20 UTC
easy hackish ??
Comment 2 Cor Nouws 2015-11-29 13:55:37 UTC
Since people need to understand ho to change this feature to test problems, I think it's more-then-a-normal-bug > Major (just IMHO)
Comment 3 Björn Michaelsen 2015-11-29 14:12:46 UTC
https://github.com/LibreOffice/core/commit/76c61ced4eaa5f69b948dca7537028eaa88225b3 should be a code pointer ...
Comment 4 Cor Nouws 2015-11-29 18:00:31 UTC
(In reply to Björn Michaelsen from comment #3)
> https://github.com/LibreOffice/core/commit/
> 76c61ced4eaa5f69b948dca7537028eaa88225b3 should be a code pointer ...

Thanks!
Does this make the issue Whiteboardable as EasyHack Beginners, UI, C++ ?
And does the same apply for bug 96132 ?
Comment 5 tommy27 2015-11-29 18:02:03 UTC
Created attachment 120878 [details]
LibO 5.1.x screenshot

@Cor
I confirm the issue in LibO 5.0.x but I see that this has been addressed in LibO 5.1.x adding "on restart" in the OpenGL UI strings. see screenshot.

so let's label this as RESOLVED WORKSFORME
probably it cannot be backported to 5.0.x because of the string freeze policy
Comment 6 Cor Nouws 2015-11-29 18:04:59 UTC
OK fine - thanks!
Comment 7 Robinson Tryon (qubit) 2015-12-18 10:39:58 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval)
[NinjaEdit]