Bug Hunting Session
Bug 96142 - <Alt>+<x> does not work in any of LO 5.1.0.0beta1 modules any longer
Summary: <Alt>+<x> does not work in any of LO 5.1.0.0beta1 modules any longer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2015-11-29 18:51 UTC by Thomas Hackert
Modified: 2016-01-18 16:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2015-11-29 18:51:31 UTC
Hello @ll,
I am used to use the mnemonics in LO as often as possible, but with the new 5.1.0.0beta1 I discovered, that it is not possible to use <Alt>+<x> any longer, if you are using the Germanophone UI on Debian Testing AMD64 ... :(

Steps to reproduce:
1. Install Germanophone lang- as well as helppack.
1. Start any module (Writer, Draw, Calc)
3. Press <Alt>+<x> to open the Extras (Tools) menu.

In Writer, there is just an "U+0074", if you open an existing document, otherwise it will be happen nothing ... :(

OS: Debian Testing AMD64
LO: Version: 5.1.0.0.beta1-buildfix1
Build-ID: 13010a13177025f633c9b85adcb3edf6920e44e3
Threads 4; Ver: 4.2; Render: default;

Have a nice evening
Thomas.
Comment 1 V Stuart Foote 2015-11-29 19:50:59 UTC
These accelerator & shortcuts like this work correctly in en-US.

The issue of the "U+0074" seems like a launch of the new "Unicode toggle" feature. And that you were in the text canvas of the Writer document adjacent to a "t", a second <alt>+"x" should revert from the "U+0074" value. But for the German local and de language, it should be honoring the use of <Alt>+C.

Please check these functions on your system:

Use the <Alt> key to toggle the underlines on or off (Linux & OS X) and review what the assigned shortcut is for the menu.  Also, check behavior of <Atl>+C and <Alt>+X as Unicode toggle--<Alt>+X as toggle seems to be incorrect.

@Samuel, did your patch of bug 73691 for German local go awry?

=-ref-=
bug 73691 --add unicode conversion shortcut like word (alt+x)

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff3c4f4c704977b2eec1dba1238b422537e413f3

with adjustment for German local replace <alt>+X with <alt>+C to allow E_xtras
http://cgit.freedesktop.org/libreoffice/core/commit/?id=ddf7618fb56c927f862de7b85f213da352cf2b26

=-=-=

Somewhat related there are issues with the StartCenter, where the UI is controlled with specific accelerators (see bug 92866 ).

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74407aef94b6d8dfdd69891c4a6e578587ef3e71
Comment 2 Cor Nouws 2015-11-30 10:29:14 UTC
H Thomas,

Is it 5.1 or 4.2 ?
Alt-X is set - initially - to show Unicode.
https://wiki.documentfoundation.org/ReleaseNotes/5.1#Unicode_character_input_with_Alt.2BX
From what I remember, for DE that should (in the mean time?) be changed to Alt+C ?

Ciao - Cor
Comment 3 Thomas Hackert 2015-12-01 05:18:32 UTC
Hello V. Stuart, Cor, *,
sorry for the delay, but I was not able to answer earlier ... :(

To V. Stuart:
I have tested all other mnemonics / accelerator keys and they work as expected – expect the <Alt>+<x> for the Extras / Tools menu ... :( In the Germanophone UI the accelerator key was always "x", so this change will be unexpected for most Germanophone users .... :(

To Cor: I meant 5.1.0.0beta1. <Alt>+<x> and <Alt>+<c> seems to do the same. They toggle unicode on and of ... :(
Do you need any further information? If so, feel free to ask :)
Have a nice day
Thomas.
Comment 4 Samuel Mehrbrodt (CIB) 2015-12-01 07:56:17 UTC
(In reply to thackert from comment #0)
> Hello @ll,
> I am used to use the mnemonics in LO as often as possible, but with the new
> 5.1.0.0beta1 I discovered, that it is not possible to use <Alt>+<x> any
> longer, if you are using the Germanophone UI on Debian Testing AMD64 ... :(

What is the Germanophone UI? Where do I find it? Which language code does it have?
Comment 5 Thomas Hackert 2015-12-01 09:20:03 UTC
Hallo Samuel, *,
(In reply to Samuel Mehrbrodt from comment #4)
> (In reply to thackert from comment #0)
> > Hello @ll,
> > I am used to use the mnemonics in LO as often as possible, but with the new
> > 5.1.0.0beta1 I discovered, that it is not possible to use <Alt>+<x> any
> > longer, if you are using the Germanophone UI on Debian Testing AMD64 ... :(
> 
> What is the Germanophone UI? Where do I find it? Which language code does it
> have?

DE_de :) But as not only Germans but also Dutch, Belgian, Austrian, Swiss and other people, who can speak, read and/or write in German, I have used Germanophone since my OOo times ... ;)
Have a nice day
Thomas.
Comment 6 V Stuart Foote 2015-12-13 17:34:43 UTC
adding to the bug 71732 Meta tracker
Comment 7 Justin L 2015-12-14 05:40:40 UTC
Thanks for reporting this bug.  It was fixed on Dec 4 (noted in bug 73691).  Marking now as "works for me".  Thomas please confirm.

The Alt-C locale fix mentioned in comment 1 didn't "replace" the alt-X sequence as expected, it just added an additional sequence. We specifically had to "unset" alt-x for about 6 locales.
Comment 8 Thomas Hackert 2015-12-14 10:17:39 UTC
Hello Justin, *,
(In reply to Justin L from comment #7)
> Thanks for reporting this bug.  It was fixed on Dec 4 (noted in bug 73691). 
> Marking now as "works for me".  Thomas please confirm.
> 
> The Alt-C locale fix mentioned in comment 1 didn't "replace" the alt-X
> sequence as expected, it just added an additional sequence. We specifically
> had to "unset" alt-x for about 6 locales.

I have tested it with

LO Version: 5.1.0.0.beta2
Build-ID: 53054959a12edc6510f51b94ddc9b73d27aedaf6
Threads 4; Ver: 4.2; Render: default; 

Gebietsschema: de-DE (de_DE.UTF-8)

(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux with DE-lang- as well as helppack on Debian Testing AMD64), but it is still not possible to use <Ctrl>+<x> to open the Extras (in English Tools) menu ... :( As there is no other version with Germanophone UI available, I am not sure, if I have to wait for the release of RC1, reopen this bug as "New" or something like that ... :(
Sorry for the inconvenience
Thomas.
Comment 9 Thomas Hackert 2015-12-18 16:56:39 UTC
Hello @ll,
this bug seems to be fixed with LO
Version: 5.1.0.1
Build-ID: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
Threads 4; Ver: Linux 4.2; Render: default; 

Gebietsschema: de-DE (de_DE.UTF-8)

on Debian Testing AMD64 (parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux).
Thanks all involved for fixing this bug :)
Have a nice evening
Thomas.
Comment 10 Cor Nouws 2015-12-18 18:47:26 UTC
same for Dutch. Thanks!