Bug Hunting Session
Bug 96161 - FILESAVE and FORMATTING: Y-axis values changed on a graphic after saving in .xlsx format
Summary: FILESAVE and FORMATTING: Y-axis values changed on a graphic after saving in ....
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: highest normal
Assignee: Markus Mohrhard
URL:
Whiteboard: interoperability target:5.3.0 target:...
Keywords: bibisected, bisected, filter:xlsx, regression
Depends on:
Blocks:
 
Reported: 2015-11-30 22:14 UTC by Juan Carlos
Modified: 2016-10-04 15:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
ZIP which contains two files: PNG showing correct values, and the XLSX file. (53.38 KB, application/zip)
2015-11-30 22:14 UTC, Juan Carlos
Details
xlsx and docx files edited in LibreOffice 5.0.3.2 (11.24 KB, application/zip)
2015-12-13 00:10 UTC, Paul
Details
New ZIP which contains both files: .ODS and .XLSX. I've made a new graphic for an easier debugging. (21.92 KB, application/zip)
2015-12-13 15:36 UTC, Juan Carlos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Carlos 2015-11-30 22:14:33 UTC
Created attachment 120904 [details]
ZIP which contains two files: PNG showing correct values, and the XLSX file.
Comment 1 Buovjaga 2015-12-01 09:40:58 UTC
Can you attach the original .ods so we can test the saving?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 Paul 2015-12-13 00:10:48 UTC
Created attachment 121252 [details]
xlsx and docx files edited in LibreOffice 5.0.3.2

Note that the X axis values in the .docx file do not agree with the .xlsx file.
Comment 3 Buovjaga 2015-12-13 14:15:45 UTC
Still waiting for ODS file so we can test.
Comment 4 Buovjaga 2015-12-13 14:17:08 UTC
Reverting component change.
Comment 5 Juan Carlos 2015-12-13 15:36:09 UTC
Created attachment 121260 [details]
New ZIP which contains both files: .ODS and .XLSX. I've made a new graphic for an easier debugging.
Comment 6 Buovjaga 2015-12-13 16:03:28 UTC
I confirm that the Y-axis labels change when saving to .xlsx with LibO 5.0.3. The legend also changes from the single blue "Y" to multiple colored points.

However, in 5.2 only legend change happens.

In 4.3, the X-axis values disappear and the chart gets the title "Y". Otherwise it stays ok, so I'm adding a bibisect request.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 917d59a84124d1022bd1912874e7a53c674784f1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-12_12:17:04
Locale: fi-FI (fi_FI)

4.3.0.1
Comment 7 Joel Madero 2015-12-14 16:50:48 UTC
Setting to:
Normal - can prevent high quality work;
Highest - really basic chart getting messed up during export to xlsx. Furthermore it's a regression.

FYI - when you check the legend settings it still only shows "Y" but they come out all wonky.

There are only 'skip'ped commits left to test.
The first bad commit could be any of:
976c469b22d9c0cd4c82eb6b70806013bdac3c79
84f786cde77ac35cf564f36e687cf2d04fb6a953
We cannot bisect more!


# bad: [dda106fd616b7c0b8dc2370f6f1184501b01a49e] source-hash-0db96caf0fcce09b87621c11b584a6d81cc7df86
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'latest' 'oldest'
# good: [0c30a2c797b249d0cd804cb71554946e2276b557] source-hash-45aaec8206182c16025cbcb20651ddbdf558b95d
git bisect good 0c30a2c797b249d0cd804cb71554946e2276b557
# good: [2ce02b2ce56f12b9fcb9efbd380596975a3a5686] source-hash-17d714eef491bda2512ba8012e5b3067ca19a5be
git bisect good 2ce02b2ce56f12b9fcb9efbd380596975a3a5686
# bad: [40875247f0002056effdf6d2fbe43627691cd86c] source-hash-93f0b14458a618ad575cd446680e5c4aa7d87bdc
git bisect bad 40875247f0002056effdf6d2fbe43627691cd86c
# bad: [07e62597be0600b763c4d18204799dcf09d2d3d9] source-hash-b2ead407c70f71974a1eac79df09072ff8bd0cc2
git bisect bad 07e62597be0600b763c4d18204799dcf09d2d3d9
# good: [65755dc98fdc972c90f86f7102d7855c833a51ec] source-hash-a75d90740647414f55ef5a37bdfb230d624ec2eb
git bisect good 65755dc98fdc972c90f86f7102d7855c833a51ec
# bad: [eb19ce6fbff2ae1fa908027d456b0dcf64ed17c2] source-hash-0cd0206fa4392d43724f630555994af842fc0733
git bisect bad eb19ce6fbff2ae1fa908027d456b0dcf64ed17c2
# bad: [f2ddff16d43319bfbff0f9d2430ccc6aa5d3cef7] source-hash-3d54555a1e7d79f00a8ba309cf821f0e5f48be21
git bisect bad f2ddff16d43319bfbff0f9d2430ccc6aa5d3cef7
# good: [552364995f5254d8adb82f154bb490911833bffd] source-hash-799fd7552f544834ae2d3b77c3ce69e36590b63a
git bisect good 552364995f5254d8adb82f154bb490911833bffd
# good: [1eeca30fa6e85c72ee2625bf80f097059b552c8f] source-hash-0dac111a3249b65eb512403897855f9d9b226f39
git bisect good 1eeca30fa6e85c72ee2625bf80f097059b552c8f
# good: [28aa92395bc8997179c2cb9e84ae5aa7014a3e68] source-hash-1acbe79da41b61f43d86eaadba3ab5e51e65528c
git bisect good 28aa92395bc8997179c2cb9e84ae5aa7014a3e68
# skip: [976c469b22d9c0cd4c82eb6b70806013bdac3c79] source-hash-5fa0adf25cfcb71129e05e7218cde46874306c15
git bisect skip 976c469b22d9c0cd4c82eb6b70806013bdac3c79
# bad: [42418d20235d141c918d9f9d969270547f1b65d0] source-hash-eeaa87c1d92c959fb4e57fa2967587b7f416470d
git bisect bad 42418d20235d141c918d9f9d969270547f1b65d0
# good: [72a64e9238ccebd924d390e474e5feca167773ed] source-hash-3df94a9272260cd839f6aec69d9f4914fc1ba565
git bisect good 72a64e9238ccebd924d390e474e5feca167773ed
# bad: [84f786cde77ac35cf564f36e687cf2d04fb6a953] source-hash-4c3cfe60ac05d5404e3f2a92fff7af2d2f38628a
git bisect bad 84f786cde77ac35cf564f36e687cf2d04fb6a953
# only skipped commits left to test
# possible first bad commit: [84f786cde77ac35cf564f36e687cf2d04fb6a953] source-hash-4c3cfe60ac05d5404e3f2a92fff7af2d2f38628a
# possible first bad commit: [976c469b22d9c0cd4c82eb6b70806013bdac3c79] source-hash-5fa0adf25cfcb71129e05e7218cde46874306c15
Comment 8 Xisco Faulí 2016-09-02 16:07:16 UTC
Hello Markus,

It looks like this regression was introduced by one of your commits in range
3df94a9272260cd839f6aec69d9f4914fc1ba565..4c3cfe60ac05d5404e3f2a92fff7af2d2f38628a
Could you please take a look whenever you have some time?
Regards
Comment 9 Xisco Faulí 2016-09-26 15:13:40 UTC
Adding Cc: to Markus Mohrhard
Comment 10 Commit Notification 2016-10-01 02:21:32 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74b2cc607448d24146bd3508abb832d6ab42cb56

tdf#96161, always write the varyColors element

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-10-04 15:40:47 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f102e2391a913acef117aed6106e635b7ab1853d&h=libreoffice-5-2

tdf#96161, always write the varyColors element

It will be available in 5.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.