Download it now!
Bug 96187 - Crash when setting animation
Summary: Crash when setting animation
Status: RESOLVED DUPLICATE of bug 96162
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2015-12-01 18:12 UTC by Laurent BP
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (9.09 KB, text/plain)
2015-12-01 22:00 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2015-12-01 18:12:50 UTC
Steps to reproduce:
1. Select an object
2. Sidebar > Custom Animation > button "+" Add Effect
3. Select any effect, OK
=> Crash
LibreOfficeDev 5.1 - Fatal Error
SEH Exception: ACCESS VIOLATION 

With Win 7, Version: 5.1.0.0.beta1-buildfix1
Build ID: 13010a13177025f633c9b85adcb3edf6920e44e3
Threads 4; Ver: Windows 6.1; Render: default;
Locale : fr-FR (fr_FR) 
Confirmed with
- LO 5.2.0.0.alpha0+ Build ID: 03c37cee476d14d1d8644ccc7ea5c69d74d9c7f9
Threads 2; Ver: Windows 6.1; Render: GL;
TinderBox: Win-x86@42, Branch:master, Time: 2015-11-28_00:15:51
Locale: fr-FR (fr_FR)
- LO 5.1.0.0.alpha1+ Build ID: f6bc5b79c31225c02e9500d0ced4bd26f998f82b
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-24_01:07:47 Locale: fr-FR (fr_FR)
Comment 1 Laurent BP 2015-12-01 20:23:55 UTC
Confirmed with Version: 5.1.0.0.alpha1+
Build ID: 229583f298b9de05e1ad1727e233d597995099e3-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-22_23:09:05
Locale: fr-FR (fr_FR)

NO CRASH with Version: 5.1.0.0.alpha1+
Build ID: f173e148d8f2d0600fd50bee05e536932d529643-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-30_22:36:37
Locale: fr-FR (fr_FR)
Comment 2 Jacques Guilleron 2015-12-01 21:21:33 UTC
Hi Laurent,

I confirm with the versions of your description on Windows 7 Home.
I set Stauts to NEW and Keywords to regression.
Comment 3 Jean-Baptiste Faure 2015-12-01 21:30:08 UTC
Reproducible under Linux with
Version: 5.1.0.0.beta1+
Build ID: 14096319475eca0c738cbd71267a1f2123361897
Threads 4; Ver: 4.2; Render: default;

Ubuntu_15.10_x86-64
Locale: fr-FR (fr_FR.UTF-8)

Best regards. JBF
Comment 4 Julien Nabet 2015-12-01 22:00:17 UTC
Created attachment 120938 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
I attached a bt with symbols
Comment 5 Maxim Monastirsky 2015-12-01 22:03:03 UTC
bisect range is 186f365a2c541c51e404b1fa819f35c9152adaf1...01de2fc790b50c04f13907026f1a7782009fea61

I suspect this is related to:

commit 536c259cb9644971d0eb0cdfb7d823c5383a5481
Author: Laurent Godard <lgodard.libre@laposte.net>
Date:   Tue Aug 25 16:38:43 2015 +0200

    tdf#67770 store sidebar elements states

The sidebar panel is now disposed & destructed while updating the effects listbox.
Comment 6 Maxim Monastirsky 2015-12-01 22:24:34 UTC

*** This bug has been marked as a duplicate of bug 96162 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:03:15 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]