Download it now!
Bug 96286 - Displaying Navigator two times (left side & side bar on the right) in an old ODP and can't get ridd off the old one on the left side
Summary: Displaying Navigator two times (left side & side bar on the right) in an old ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-06 10:56 UTC by riesslibo
Modified: 2015-12-11 12:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example odp with navigator behaviour (1000.88 KB, application/vnd.oasis.opendocument.presentation)
2015-12-06 10:57 UTC, riesslibo
Details
screenshot with showing navigator two times (98.75 KB, image/png)
2015-12-06 10:57 UTC, riesslibo
Details
same behavior with a new slide file after closing the old one (69.91 KB, image/png)
2015-12-06 11:00 UTC, riesslibo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description riesslibo 2015-12-06 10:56:13 UTC
Strange behaviour, see attached screenshot. System Win7x64 with V5.1.0.0 beta2

Problem statement:
When I open an old odp (see attached example) the navigator is displayed on the left side or as a free loating one. When i hit on the navigator symbol in the side bar, a second navigator in the side bar on the right side appears. Two navigators are displayed. Hitting again on the navigator symbol, the right one in the sidebar disappear, but the "old" one still is displayed. Hitting the red cross on the free floating one have the same effect as hitting the navigator symbol in the sidebar (appearing and disappearing the navigator on the right and not the left/or free floating one). Searching in Menu or Symbollist for another possibility to cancel the old navigator was with no result.

Steps to reproduce
1. Open attached ODP (sorry, this is a commercial slide show, not confidential but with infos about a product of our company, I took this one without changes to be sure to get this effect)

2. Display the side bar and hit on the navigator symbol in the side bar

3. the second Navigator is displayed 

4. hitting again the second Navigator disappear but the "Old" one on the left side or as floating window still there (even hitting the red cross to close the free floating navigator window just show and hide the navigator in the side bar

Expected behaviour: Hm, just one navigator? Or a function to close both of them (even if I don't understand to have two navigator appearances)
Comment 1 riesslibo 2015-12-06 10:57:08 UTC
Created attachment 121069 [details]
Example odp with navigator behaviour
Comment 2 riesslibo 2015-12-06 10:57:41 UTC
Created attachment 121070 [details]
screenshot with showing navigator two times
Comment 3 riesslibo 2015-12-06 10:59:38 UTC
Playing with this a little bit around, I get this behaviour in the Impress modul without such an old odp, see screenshot with a new slide file. ... strange ...
in V5.1.0.0beta 2 observed
in v5.0.2.2 not observed
Comment 4 riesslibo 2015-12-06 11:00:27 UTC
Created attachment 121071 [details]
same behavior with a new slide file after closing the old one
Comment 5 riesslibo 2015-12-06 11:04:35 UTC
ahh, additional information: in contradiction to my comment (odp unchanged) I have to shorten it in v5.1.0.0 beta2 to reduce the size for attaching here. But the same effects appears after saving it with this Impress version ...
Comment 6 Cor Nouws 2015-12-06 11:45:21 UTC
Interesting times in Karslbad, Lothar ;)
I do not see the two Navigators in 5.1.0beta1 on Ubuntu.
Did you try with a clear user profile too?

Grüss, Cor
Comment 7 riesslibo 2015-12-06 12:47:16 UTC
Ahh, Cor does always have a tipp, jepp, I did rename both user profile (directory "4"), for LibreOffice and for LibreOfficeDev, give it a try for the file and no "old" navigator occurs when opening it! 

Thanks Cor, yes , indeed, interesting times with and besides LibreOffice. 

So, in consequence, do I have to remove my user profile with the new Version 5.1?
Or is this a side effect of the LibreOfficeDev profile?
If the effect is out of the Dev profile perhaps I should close this bug-item, Cor, what do you think?
Comment 8 Buovjaga 2015-12-06 13:46:48 UTC
Apparently problems usually appear in the file registrymodifications.xcu in the profile folder so you could possibly compare the old file with the newly generated one.

Closing as WFM like we normally do with these profile things.
Comment 9 Cor Nouws 2015-12-07 11:41:23 UTC
NOTE: For Userprofile and the registrymodifications.xcu :

See here https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile
Read careful :)

There is no interaction between user profiles of different (dev.) versions.

Ciao - Cor
Comment 10 Samuel Mehrbrodt (CIB) 2015-12-11 12:06:35 UTC
This was caused by commit 6f493f9e379af1e005b85606c6aab515726be993 which has been reverted for now (commit f1df1056399759e05bed9e9f94208671ca333d39 ).