Bug Hunting Session
Bug 96288 - Formatting Section read-only even not marked as such and contents on separate pages
Summary: Formatting Section read-only even not marked as such and contents on separate...
Status: RESOLVED DUPLICATE of bug 117260
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.4.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC Read-Only
  Show dependency treegraph
 
Reported: 2015-12-06 13:28 UTC by Ari Latvala
Modified: 2018-06-07 06:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
DOC file contents on several pages insead of two (61.50 KB, application/msword)
2015-12-06 13:28 UTC, Ari Latvala
Details
PDF version showing the expected layout (26.87 KB, application/pdf)
2015-12-06 13:29 UTC, Ari Latvala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ari Latvala 2015-12-06 13:28:57 UTC
Created attachment 121077 [details]
DOC file contents on several pages insead of two

Libre Office 5.0.4.1 on Windows 7 64-bit.

Opening attached DOC file containing two sections showing locks for both and other one is locked, even though neither of those are selected to be locked. 

Not able to delete extra page break between sections without activating "Ignore protection".

Contents splitted incorrectly on separate pages between sections and before the start of two column mode part. Compare DOC to PDF version of the same document.
Comment 1 Ari Latvala 2015-12-06 13:29:27 UTC
Created attachment 121078 [details]
PDF version showing the expected layout
Comment 2 Buovjaga 2015-12-08 09:56:20 UTC
Where can I see the locks?
Comment 3 Ari Latvala 2015-12-08 14:51:45 UTC
Clarification, locks are there under "Format, Sections" in front of each section name, but they appear to be open (at least on this Linux 64-bit version, originally problem was identified on Windows 7 64-bit platform) and "Write Protection Enabled" check box is not selected for either section. 

Still not able to delete the page brake between section 1 and 2, unless I've activated "Ignore protection" option on Tools, Options, LibreOffice Writer, Formatting Aids, Protected Areas, Ignore protection". Trying to delete extra page break between sections just generates error: "Read-Only Content, Write-protected content cannot be changed. No modifications will be accepted. OK".
Comment 4 Buovjaga 2015-12-10 08:17:13 UTC
Yes they are unlocked on Win.

I was able to delete all page breaks even without the Ignore option enabled.

In 4.3 there are no page breaks to begin with!

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)

4.3.0.1
Comment 5 Ari Latvala 2016-02-13 23:35:47 UTC
Just tested with LO 5.1.0.3 on Windows 7 64-bit. This originally 2 page document still divided into 4 pages and when trying to delete page brakes between sections, I am able to delete first one between page 1 and 2 but when trying to do the same for the next page brake, it still gives that error, until I have "Ignore Protection" selected on Tools, Options, LibreOffice Writer, Formatting Aids -menu. Still locks are open under "Format, Sections" -menu.
Comment 6 Ari Latvala 2017-03-19 08:29:50 UTC
Problem still exist on LibreOffice 5.3.1
Comment 7 Ari Latvala 2018-06-07 06:36:43 UTC
Duplicate of Bug 117260 - FILEOPEN: DOC Extra page breaks before and after 2 column section

*** This bug has been marked as a duplicate of bug 117260 ***