Bug 96293 - FORMATTING: Recent colors are not memorized in the "Select the color" dialog called from the sidebar
Summary: FORMATTING: Recent colors are not memorized in the "Select the color" dialog ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Color-Picker-Widget
  Show dependency treegraph
 
Reported: 2015-12-06 18:16 UTC by Doctor Rover
Modified: 2016-10-23 19:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Doctor Rover 2015-12-06 18:16:52 UTC
The colors are not remembered in the section Recent of the "Select the color" dialog called from the sidebar. While you are working with a single object, the Recent section is filled by colors, but as soon as you switch focus out from this object, the Recent section becomes empty again.
Comment 1 Buovjaga 2015-12-06 18:24:03 UTC
Reproduced.

1. Draw a shape
2. Set color to area or line from sidebar
3. Deselect shape
4. Select shape again and check recent colors

Changing component to LibreOffice as this affects every component with drawing features.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)
Comment 2 Maxim Monastirsky 2015-12-06 18:27:20 UTC
Yes, it's a well known problem. The recent colors are stored in PaletteManager, which is a member of the button controller. So when the button + anything related are destroyed, we're losing the recent list as well.
Comment 3 Doctor Rover 2016-10-23 18:04:21 UTC
In the Alpha version of LibreOffice 5.3.0, the issue seems to be fixed. I see the recent colors remembered among all the color pickers and moreover between different LO components. Also the recent colors are now memorized between LO restarts.
Thanks for the fix to everyone involved!
Comment 4 Doctor Rover 2016-10-23 18:06:09 UTC
Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ru-RU (ru_RU.UTF-8);
Comment 5 Yousuf Philips (jay) (retired) 2016-10-23 18:13:22 UTC
Yes it was fixed with this patch.

https://gerrit.libreoffice.org/#/c/27688/