Bug Hunting Session
Bug 96300 - Wrong hyphenation in German and Italian text using the MS-font “Calibri” and TDF “Carlito” (ligatures duplicated at end and start of line)
Summary: Wrong hyphenation in German and Italian text using the MS-font “Calibri” and ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 96841 97740 98055 (view as bug list)
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2015-12-06 22:59 UTC by Karl Zeiler
Modified: 2016-08-04 16:02 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
example file (22.25 KB, application/vnd.oasis.opendocument.text)
2015-12-06 22:59 UTC, Karl Zeiler
Details
LO5 wrong hyphenation results (51.80 KB, application/pdf)
2015-12-06 23:04 UTC, Karl Zeiler
Details
Carlito and Calibri bad hyphenation example (odt) (12.04 KB, application/vnd.oasis.opendocument.text)
2015-12-12 16:27 UTC, Carlo Strata
Details
Carlito and Calibri bad hyphenation example (native pdf export) (78.30 KB, application/x-download)
2015-12-12 16:28 UTC, Carlo Strata
Details
Carlito and Calibri bad hyphenation example (native pdf export) (77.64 KB, application/pdf)
2016-02-11 23:23 UTC, Carlo Strata
Details
LO 5.1.1.1 good hyphenation results (54.52 KB, application/pdf)
2016-02-11 23:29 UTC, Carlo Strata
Details
Carlito and Calibri 5.1.1.1 good hyphenation example (native pdf export) (77.64 KB, application/pdf)
2016-02-11 23:33 UTC, Carlo Strata
Details
LO-document with hyphenation-error Danish (9.65 KB, application/vnd.oasis.opendocument.text)
2016-02-29 20:16 UTC, Jensen10
Details
PDF test hyphenation error in LO (25.68 KB, application/pdf)
2016-02-29 20:18 UTC, Jensen10
Details
pdf exported LO-document with hyphenation-error Danish, OK! (25.08 KB, application/pdf)
2016-02-29 21:09 UTC, Carlo Strata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Zeiler 2015-12-06 22:59:57 UTC
Created attachment 121091 [details]
example file

The attached example file contains two boxes with German text. Box 1 is formatted with the standard font “Times New Roman”, box 2 with the MS-Font “Calibra”. The hyphenation function is activated. Open this example file.

Box 1: Result of hyphenation
- all words are hyphenated correctly (green colorized)

Box 2: Result of hyphenation
- words with “tt” are hyphenated → “tt-tt” (wrong - red colorized)
- words with “ff” are hyphenated →”ff-ff” (wrong - red colorized)
expected behavior:
- words with “tt” are hyphenated →”t-t”
- words with “ff” are hyphenated → “f-f”

Affected operation systems: Windows all
Affected LO versions: 5.0.x and 5.1.0 beta 2

Additionally, the following line after the word wrap seems to be moved beyond the left margin. (s. attachement: LO5_wrong_hyphenation_results.pdf)

See also the thread on de-discuss:
http://www.mail-archive.com/discuss@de.libreoffice.org/msg19191.html
Comment 1 Karl Zeiler 2015-12-06 23:04:56 UTC
Created attachment 121092 [details]
LO5 wrong hyphenation results
Comment 2 k-j 2015-12-07 06:40:05 UTC
I can confirm it with LibO 5.1.0 beta2 (64bit) and WIN 10 1511
Comment 3 Jochen 2015-12-07 07:39:57 UTC
I can confirm it with LibO 5.0.3 and Windows 8.1 (64 bit)
Comment 4 Christian Lohmaier 2015-12-07 17:59:43 UTC
the tt and ff clearly are ligatures, thus the problem likely is in ligature handling (so there should be way more modern fonts experiencing the problem)
Comment 5 Carlo Strata 2015-12-12 16:24:34 UTC
Hi Everyone!

In some Italian word and only with some fonts, hyphenation fails doubling some letters on both lines. Carlito and Calibri appear to be similar for better and for worse!

Carlito too has this problem!

Have a nice day,

Carlo
Comment 6 Carlo Strata 2015-12-12 16:27:18 UTC
Created attachment 121244 [details]
Carlito and Calibri bad hyphenation example (odt)
Comment 7 Carlo Strata 2015-12-12 16:28:01 UTC
Created attachment 121245 [details]
Carlito and Calibri bad hyphenation example (native pdf export)
Comment 8 Carlo Strata 2015-12-12 16:29:20 UTC
My system is:

 * Microsoft Windows 10 Home, 64 bit (x86-64), Italian, daily updated;
 * Java 1.8.0 update 66 (x86-64) configured on LibreOffice in Tools ->
   Options -> LibreOffice -> Advanced;
 * LibreOffice 5.0.4.2, win64, custom install -> full Optional
   Components selected, Italian help installed.
Comment 9 Carlo Strata 2016-02-11 23:23:13 UTC
Created attachment 122554 [details]
Carlito and Calibri bad hyphenation example (native pdf export)

With LibreOffice 5.1.1.1, Windows, x64 it seems that all is ok and the bug is fixed. I attach the native exported pdf of the  Carlito and Calibri bad hyphenation example (odt).

Have All a nice day,

Carlo
Comment 10 Carlo Strata 2016-02-11 23:29:43 UTC
Created attachment 122555 [details]
LO 5.1.1.1 good hyphenation results

I native export to pdf also the original odt file with very good (correct!) results.

I think the bug is closed fixed!

Carlo
Comment 11 Carlo Strata 2016-02-11 23:33:55 UTC
Created attachment 122556 [details]
Carlito and Calibri 5.1.1.1 good hyphenation example (native pdf export)

I change my last description only to reflect the correctness of the result.
Comment 12 Carlo Strata 2016-02-11 23:35:39 UTC
See attached LO 5.1.1.1 native pdf export to understand the fix (at least on Windows x64 5.1.1.1 build).
Comment 13 Adolfo Jayme 2016-02-13 06:22:40 UTC
If a bug is no longer reproducible, the correct resolution is “WORKSFORME”, not “FIXED”.
Comment 14 Karl Zeiler 2016-02-16 10:29:24 UTC
The bug is still reproducible in L0 5.0.5.2 release. Tested with above mentioned example file. Therefore I reopen the bug.

In my opinion, it is an annoying bug: The ligatures duplicated at end and start of line appear in native pdf export too. Please, fix this bug as soon as possible!
Comment 15 Robinson Tryon (qubit) 2016-02-18 15:07:21 UTC
(In reply to Karl Zeiler from comment #14)
> The bug is still reproducible in L0 5.0.5.2 release. Tested with above
> mentioned example file. Therefore I reopen the bug.

As there hasn't been a fix provided yet, the status should move back to NEW.
Comment 16 Buovjaga 2016-02-18 18:37:57 UTC
*** Bug 97740 has been marked as a duplicate of this bug. ***
Comment 17 Buovjaga 2016-02-21 20:03:42 UTC
*** Bug 98055 has been marked as a duplicate of this bug. ***
Comment 18 Carlo Strata 2016-02-24 20:12:41 UTC
(In reply to Robinson Tryon (qubit) from comment #15)
> (In reply to Karl Zeiler from comment #14)
> > The bug is still reproducible in L0 5.0.5.2 release. Tested with above
> > mentioned example file. Therefore I reopen the bug.
> 
> As there hasn't been a fix provided yet, the status should move back to NEW.

Why not CLOSED -> WORKSFORME if in 5.1.1.1 (I don't know in 5.1.x at all) the bug isn't reproducible any more?

Have All a nice evening,

Carlo
Comment 19 Robinson Tryon (qubit) 2016-02-25 15:05:09 UTC
(In reply to Carlo Strata from comment #18)
> (In reply to Robinson Tryon (qubit) from comment #15)
> > (In reply to Karl Zeiler from comment #14)
> > > The bug is still reproducible in L0 5.0.5.2 release. Tested with above
> > > mentioned example file. Therefore I reopen the bug.
> > 
> > As there hasn't been a fix provided yet, the status should move back to NEW.
> 
> Why not CLOSED -> WORKSFORME if in 5.1.1.1 (I don't know in 5.1.x at all)
> the bug isn't reproducible any more?

Sorry, my misunderstanding reading the version numbers -- my eyes must have glazed over there. Yes, if it's fixed in 5.1, it should be RESOLVED as WORKSFORME.
Comment 20 Buovjaga 2016-02-28 16:49:04 UTC
*** Bug 96841 has been marked as a duplicate of this bug. ***
Comment 21 Jensen10 2016-02-28 17:18:20 UTC
Wrong hyphenation in Danish still exist in LO 5.1.0.3. (win7 64-bit)
It seems to bee a font problem.
When using for example font "Palatino Linotype" the hyphenation is "etikett-ttebøger", should be "etiket-tebøger". Also other fonts make this problem. But with Arial or Times New Roman, no problems.
The second "tt" is out of the left margin in beginning of the line.
Is it not only 'tt' but also other letters are misspelled
When using the spell-function (Function>Language>hyphenation )on the wrong word, the misspell disappear.
Comment 22 Carlo Strata 2016-02-29 19:25:00 UTC
(In reply to Jensen10 from comment #21)
> Wrong hyphenation in Danish still exist in LO 5.1.0.3. (win7 64-bit)
> It seems to bee a font problem.
> When using for example font "Palatino Linotype" the hyphenation is
> "etikett-ttebøger", should be "etiket-tebøger". Also other fonts make this
> problem. But with Arial or Times New Roman, no problems.
> The second "tt" is out of the left margin in beginning of the line.
> Is it not only 'tt' but also other letters are misspelled
> When using the spell-function (Function>Language>hyphenation )on the wrong
> word, the misspell disappear.

Hi Jensen10,

two questions:
1) could you post here a simple odt file with whom we can verify your case?
2) have you tried to oper your file with 5.1.1.x (I'm now using the 5.1.1.2 Win_x64 that you can still find only here http://dev-builds.libreoffice.org/pre-releases/)?

Thank you very much,

Carlo
Comment 23 Jensen10 2016-02-29 20:16:36 UTC
Created attachment 123089 [details]
LO-document with hyphenation-error Danish

Enclosed test document from LO 5.1.0.2 with hyphenation-error, font Palatino Linotype
Comment 24 Jensen10 2016-02-29 20:18:19 UTC
Created attachment 123090 [details]
PDF test hyphenation error in LO

Enclosed pdf-file shows how hyphenation looks in the document  LO 5.1.0.3 Danish
Comment 25 Jensen10 2016-02-29 21:01:15 UTC
Hi Carlo.
Just installed LO 5.1.1.1 and tested both the uploaded test-file, and tried a new file.
Here the problem looks to be solved. Some other tests may show, if it is so. Hope so.
Comment 26 Carlo Strata 2016-02-29 21:09:15 UTC
Created attachment 123092 [details]
pdf exported LO-document with hyphenation-error Danish, OK!

(In reply to Jensen10 from comment #25)
> Hi Carlo.
> Just installed LO 5.1.1.1 and tested both the uploaded test-file, and tried
> a new file.
> Here the problem looks to be solved. Some other tests may show, if it is so.
> Hope so.

I have open attachment in comment #24, native exported with LO 5.1.1.2 and compared the pdf with that in comment #25.

The output with 5.1.1.2 is OK (I have attached it here)! I think we could CLOSE -> WORKSFORME this bug, do you agree with me?

Have a nice evening,

Carlo
Comment 27 Jensen10 2016-02-29 21:15:17 UTC
(In reply to Carlo Strata from comment #26)
> Created attachment 123092 [details]
> pdf exported LO-document with hyphenation-error Danish, OK!
> 
> (In reply to Jensen10 from comment #25)
> > Hi Carlo.
> > Just installed LO 5.1.1.1 and tested both the uploaded test-file, and tried
> > a new file.
> > Here the problem looks to be solved. Some other tests may show, if it is so.
> > Hope so.
> 
> I have open attachment in comment #24, native exported with LO 5.1.1.2 and
> compared the pdf with that in comment #25.
> 
> The output with 5.1.1.2 is OK (I have attached it here)! I think we could
> CLOSE -> WORKSFORME this bug, do you agree with me?
> 
> Have a nice evening,
> 
> Carlo

I agree. If the problem shows again I shall reopen.
Also nice evening to Carlo
Comment 28 Carlo Strata 2016-02-29 21:38:44 UTC
I close this bug with RESOLVED -> WORKSFORME because it seems from various tests that since 5.1.1.1 version the problem doesn't appear any more.

This is confirmed also in version 5.1.1.2, Win_x64.

Carlo
Comment 29 Fabrizio 2016-06-04 08:36:07 UTC
It happens using hyphenation function on LO 5.1.2.2 (italian version)

The program crashed everytime using any type of characters (Times Roman too)
Comment 30 Buovjaga 2016-06-04 13:32:31 UTC
(In reply to Fabrizio from comment #29)
> It happens using hyphenation function on LO 5.1.2.2 (italian version)
> 
> The program crashed everytime using any type of characters (Times Roman too)

You are talking about crashing. Original report is about the problem: words with “tt” are hyphenated → “tt-tt”

Please clarify, what you mean by your comment.
Comment 31 mahfiaz 2016-08-04 16:02:16 UTC
I assume Fabrizio's problem is not serious enough. Closed.