Bug 96328 - delay in appearance of text in dropdown menus and tooltips with OpenGL on
Summary: delay in appearance of text in dropdown menus and tooltips with OpenGL on
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-OpenGL
  Show dependency treegraph
 
Reported: 2015-12-08 02:31 UTC by yanjingtao
Modified: 2016-06-24 12:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A second gray menu (28.98 KB, image/png)
2015-12-08 02:31 UTC, yanjingtao
Details
hint (26.76 KB, image/png)
2015-12-08 02:35 UTC, yanjingtao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yanjingtao 2015-12-08 02:31:41 UTC
Created attachment 121128 [details]
A second gray menu

When call a menu, like click MainMenu, right click in everywhere, it will show a gray menu with nothing, also this affect in hint.


Version: 5.1.0.0.beta2 (x64)
Build ID: 53054959a12edc6510f51b94ddc9b73d27aedaf6
Threads 8; Ver: Windows 6.1; Render: GL; 

Locale: zh-CN (zh_CN)
Comment 1 yanjingtao 2015-12-08 02:35:10 UTC
Created attachment 121129 [details]
hint
Comment 2 tommy27 2015-12-08 08:37:22 UTC
it seems that there's a delay in painting the dropdown menus and tooltips
menu background appears first and text appears later

I confirm bug under Win8.1 x64 using LibO 5.2.0.0.alpha0+
Build ID: 51a5dfd783bfc1efc52a791aab4114039581252f
Threads 4; Ver: Windows 6.2; Render: GL; 

TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-04_10:49:33
Locale: it-IT (it_IT)
Comment 3 tommy27 2015-12-08 08:39:22 UTC
the issue is related to OpenGL
if you turn it off from Tools/Options/View it works fine
Comment 4 Richard Prins 2016-03-08 15:37:17 UTC
I've been getting the same bug in Windows 10 w/ 5.1.1.1. Additionally, in Calc cells were sometimes not displaying anything or just dots in stead of text. Turning of force OpenGL in settings as tommy27 indicates worked for me. As text in spreadsheats is often not displaying, this is a major bug. A fix would be not to force OpenGL on Windows (10).
Comment 5 Jan Holesovsky 2016-06-24 12:47:34 UTC
I believe this bug is gone with the recent improvements in the OpenGL rendering.  Please re-open if you are still seeing it with the most recent LibreOffice.