Bug 96373 - Unable to Select Some Combinations of Document Background and Default Font Color
Summary: Unable to Select Some Combinations of Document Background and Default Font Color
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y
  Show dependency treegraph
 
Reported: 2015-12-10 00:09 UTC by ladyquelambe
Modified: 2019-05-11 15:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ladyquelambe 2015-12-10 00:09:46 UTC
Tools->Options->Appearance. When I choose 80% gray for document background, I can't select black or blue for the font color (the setting is ignored and all text I type is white), but I can select light colors such as yellow. 

Similarly, if I select black for document background, I can't select blue for font color.

No options in Tools->Options->Accessibility are checked.

It seems this functionality might be intentional:
https://www.libreoffice.org/get-help/accessibility/#_Colors%20and%20Fonts

but is there no way to override it? For my own accessibility issues, I need a dark document color AND a moderately dark font color.
Comment 1 Buovjaga 2015-12-14 10:36:40 UTC
Reproduced.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)
Comment 2 Buovjaga 2016-06-17 20:41:26 UTC
OS is All, because I could repro on Win..
Comment 3 QA Administrators 2017-09-01 11:16:15 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2018-10-11 21:44:01 UTC
Still reproducible.

Version: 6.2.0.0.alpha0+
Build ID: 425af6845ebe066c950b0b63f50563e067485f3e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: threaded

The tragedy is, that LibreOffice has so many bugs with missing or insufficient contrast--and this working contrast setting annoys people.
Comment 5 Cor Nouws 2019-05-11 11:31:20 UTC
(In reply to ladyquelambe from comment #0)

> but is there no way to override it? For my own accessibility issues, I need
> a dark document color AND a moderately dark font color.

I think the behavior can be changed if you go to the font attribute (either in the style, of in Format>Character) On the Font effects tab, the color is set Automatic. Does it help if you change that?
Comment 6 Buovjaga 2019-05-11 15:10:18 UTC
Tested the grays with 6.3 and the switch is now made only at Dark Gray 2, so nowhere near the lightness of 80% (Light Gray 3, I think).
Also, I can change the font colour to black with Dark Gray 2 background colour.
Let's close.