Bug Hunting Session
Bug 96405 - UI Can't rename shape anymore
Summary: UI Can't rename shape anymore
Status: RESOLVED DUPLICATE of bug 101193
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Context-Menu a11y Shapes
  Show dependency treegraph
 
Reported: 2015-12-11 10:36 UTC by Katarina Behrens (CIB)
Modified: 2018-03-12 20:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Katarina Behrens (CIB) 2015-12-11 10:36:21 UTC
This used to work in Draw/Impress 4.3.x at least:

* insert a shape
* right-click the shape, select 'Name ...' from the context menu
* rename the shape

It doesn't anymore with 5.1, maybe already 5.0 (haven't tried). There is no 'Name' context menu entry and I've been unable to find any other menu or button to access renaming the shape functionality (but maybe I just suck at searching).

I'm implementing some stuff around textbox chaining and for that it's better when shapes have some convenient names. It's also useful when writing macros or tests and one needs to refer to shapes by names.

So please put the context menu back or add some regular menu, sidebar button, I don't care ... I just want to be able to rename shapes
Comment 1 Regina Henschel 2015-12-11 15:46:30 UTC
In LO5.2 it is in menu 'Modify' in Draw, and in menu 'Format' in Impress. Same for tool "Description".
Comment 2 raal 2015-12-11 17:28:52 UTC
confirm in Version: 5.2.0.0.alpha0+
Build ID: de9d0e797903e7ecc19be2b05c7e89d5936ae02d
Threads 4; Ver: Linux 4.2; Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-12-03_04:13:00
and 5.0.2.2

works in Version:  4.4.0.0.alpha2+
Comment 3 Joel Madero 2015-12-14 15:42:38 UTC
I suspect this was one of the 1000 minor UI changes that were purposefully done by someone in design. If so, they may refuse to add it back....I'll see if I can find the culprit

de40093fafa9def4c732742292238d96f8aa1a81 is the first bad commit
commit de40093fafa9def4c732742292238d96f8aa1a81
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Wed May 27 17:31:10 2015 +0800

    source-hash-f11863d43d96c4bcad9ae43ceb25c05d9a94307d
    
    commit f11863d43d96c4bcad9ae43ceb25c05d9a94307d
    Author:     Yousuf Philips <philipz85@hotmail.com>
    AuthorDate: Wed Dec 24 01:48:22 2014 +0400
    Commit:     Yousuf Philips <philipz85@hotmail.com>
    CommitDate: Tue Dec 23 22:55:35 2014 +0000
    
        fdo#86614 reorganize image, shape and line context menus
    
        Change-Id: I87274670fd2c092bd6ea7f7dfb67f9db76865c96
        Reviewed-on: https://gerrit.libreoffice.org/13632
        Reviewed-by: Yousuf Philips <philipz85@hotmail.com>
        Tested-by: Yousuf Philips <philipz85@hotmail.com>

:040000 040000 f7e021bd48de1700d3e92408732e4f564d1183d7 cf131a45f4b274a9aeba4590e894ebe47dfdd74e M	opt

# bad: [dda106fd616b7c0b8dc2370f6f1184501b01a49e] source-hash-0db96caf0fcce09b87621c11b584a6d81cc7df86
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'latest' 'oldest'
# bad: [0c30a2c797b249d0cd804cb71554946e2276b557] source-hash-45aaec8206182c16025cbcb20651ddbdf558b95d
git bisect bad 0c30a2c797b249d0cd804cb71554946e2276b557
# bad: [770ff0d1a74d2450c2decb349b62c5087e12c46b] source-hash-549b7fad48bb9ddcba7dfa92daea6ce917853a03
git bisect bad 770ff0d1a74d2450c2decb349b62c5087e12c46b
# good: [227af65db5e34efcf8dcb0b53333efecd30f37f8] source-hash-193c7ba9be48f00b46f9e789f233db577e7b3303
git bisect good 227af65db5e34efcf8dcb0b53333efecd30f37f8
# good: [78b395d05689a5207f2ec4cc29ec296d64076a96] source-hash-a2e4be6ded508030a6c2a33919cbe8cb504382e0
git bisect good 78b395d05689a5207f2ec4cc29ec296d64076a96
# bad: [8dd6442885c969ae43ae5ff9ddfc53c9f04a9c27] source-hash-d07f0997c54e9cef31d996ebeb2aabfb4b4e0265
git bisect bad 8dd6442885c969ae43ae5ff9ddfc53c9f04a9c27
# good: [0c544096152075c642ed598111cb02e8b74161ee] source-hash-1ac3ad7743c7c98b83f7a8a4c3e03a83721b46b9
git bisect good 0c544096152075c642ed598111cb02e8b74161ee
# good: [6f480fd1b126889647b65c389ad0a1b58d8167f7] source-hash-07b303bc14d33619782fcfef0c7d94b14b1a1e55
git bisect good 6f480fd1b126889647b65c389ad0a1b58d8167f7
# good: [afee160499eb7fbd8f79285f216c4e24e9524dc6] source-hash-310eb66522ff30492e8b3cd86dbafaeb52cdff90
git bisect good afee160499eb7fbd8f79285f216c4e24e9524dc6
# bad: [de40093fafa9def4c732742292238d96f8aa1a81] source-hash-f11863d43d96c4bcad9ae43ceb25c05d9a94307d
git bisect bad de40093fafa9def4c732742292238d96f8aa1a81
# good: [621a5d356be679ae6920299c7a651d7ea4fcc937] source-hash-548dbc6bd9c4253f27e6f35578e4a4699902150e
git bisect good 621a5d356be679ae6920299c7a651d7ea4fcc937
# good: [6e45f7e71e512a5975139e07e44cc245f0e0b682] source-hash-2e9a3ad1c6ce34af70d007cb6eda54888139f250
git bisect good 6e45f7e71e512a5975139e07e44cc245f0e0b682
# good: [aa4dd4d1dfec0025aac3146bc7ec6fd301250ee9] source-hash-f244b3120ef7bf183186bcf02cf4a9c4ab4faed7
git bisect good aa4dd4d1dfec0025aac3146bc7ec6fd301250ee9
# good: [18ed2be8fe4eefc57cf57e2449637cd5f8044ddb] source-hash-ec353f5fee16b9a2012ae2a2a4b1371f2228aae7
git bisect good 18ed2be8fe4eefc57cf57e2449637cd5f8044ddb
# first bad commit: [de40093fafa9def4c732742292238d96f8aa1a81] source-hash-f11863d43d96c4bcad9ae43ceb25c05d9a94307d
Comment 4 Joel Madero 2015-12-14 15:49:27 UTC
@Jay - one of our main contributors is pretty unhappy with this change you made....no clue if you'll reconsider but you can explain the decision.
Comment 5 Katarina Behrens (CIB) 2015-12-14 17:30:57 UTC
Ah stoopid me, it is indeed in Format menu in Impress and Modify menu in Draw (but I swear I searched there and didn't see it)

I'm fine with making this NOTABUG as long as the functionality missing from context menu can be reached by some other means (it isn't the case e.g. in bug 96478)

@Joel: nobody ever referred to me as 'one of our main contributors' before ;)
Comment 6 Yousuf Philips (jay) (retired) 2015-12-15 12:41:52 UTC
From bug 90427 comment 2.

Yes it was removed as part of the context menu clean up. The option to add/edit a name or description was added to the menu to the Format menu in Impress and is available in the Modify menu in Draw.

The ability to modify a shape's name in Navigator should be integrated into the context menu, as mentioned in bug 90244.
Comment 7 Xisco Faulí 2016-09-02 15:28:28 UTC
Hello Katarina,

Is it still a bug? if not, could you please close it?

Regards
Comment 8 Katarina Behrens (CIB) 2016-09-02 16:18:11 UTC
> Is it still a bug? if not, could you please close it?

It is a bug for me - I prefer to have the entry present in context menu and I disagree that the status quo would be a better UX. 

Then again, I seem to be the only one, so maybe someone else who is convinced this is NOTABUG can close it accordingly
Comment 9 Regina Henschel 2016-09-02 16:48:04 UTC
I like it in context menu too. It is not only shorter, but in addition it has no unique place now: Writer and Impress->Format menu; Draw->Modify menu; Calc->context menu.

Customizing the context menu is not really an option, because you have to do it in each module and for each kind of object.
Comment 10 Yousuf Philips (jay) (retired) 2016-09-03 19:06:36 UTC
Yes the context menu is definitely a shorter distance to travel and it may be useful to have it in modules where most users regularly name shapes and the context menu is small. Another option is to assign a simple shortcut key to it (e.g. F2), like we've done with F4 opening the position and size dialog in impress/draw.

Regarding the location of the item in the menu not being consistent across modules, i had already noticed that it wasnt in the menu in Calc and it is on my to do list to fix. Draw's menus havent been reorganized yet, so nothing is consistent there with other modules.
Comment 11 Xisco Faulí 2017-09-13 16:45:28 UTC
Actually, the keyword 'bisected' is missing here.

Adding Cc: to Yousuf Philips
Comment 12 V Stuart Foote 2018-03-12 20:21:41 UTC

*** This bug has been marked as a duplicate of bug 101193 ***