Bug 96415 - Writer: cannot set desired borders (bottom) if cell crosses the page
Summary: Writer: cannot set desired borders (bottom) if cell crosses the page
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Table-Borders
  Show dependency treegraph
 
Reported: 2015-12-11 14:35 UTC by aqcoder
Modified: 2020-09-28 16:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
the odt file witch can show the bug (9.17 KB, application/vnd.oasis.opendocument.text)
2015-12-11 14:35 UTC, aqcoder
Details
show the problem (1.29 MB, video/x-flv)
2015-12-15 15:22 UTC, aqcoder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aqcoder 2015-12-11 14:35:18 UTC
Created attachment 121224 [details]
the odt file witch can show the bug

It paint the cell box at a wrong way which celll across page.

Step to show bug:

1. Insert a table which only have one cell.
2. Set no boders except bottom line.
3. Make the cell acroos page. Then it paint the top line of the cell at the second page.

Iam not sure that it is a bug?

screenshot:
http://7xjcd4.com1.z0.glb.clouddn.com/bog_lo_bug_cell_paint_1.png
http://7xjcd4.com1.z0.glb.clouddn.com/bog_lo_bug_cell_paint_2.png
Comment 1 m.a.riosv 2015-12-11 19:14:00 UTC
Hi @agcoder, thanks for reporting.

There is an option in the Menu/Table/Table properties - Text Flow tab - Allow row to break across pages and columns.
Deactivating the option, seems is what you want.

Resolved as not a bug, please if you are not agree, reopen it.
Comment 2 aqcoder 2015-12-15 15:22:01 UTC
Created attachment 121316 [details]
show the problem
Comment 3 aqcoder 2015-12-15 15:29:38 UTC
Thanks @m.a.riosv!

It is necessary to across the page for the cell.
And it work well when set top line only.
It just seem to has problem when set bottom line only.

There is a vidio to show the program floww or see at the attachment:

http://7xjcd4.com1.z0.glb.clouddn.com/bog_lo_bug_cell_paint_vidio.flv
http://7xjcd4.com1.z0.glb.clouddn.com/bog_lo_bug_cell_paint_vidio2.avi

I am not sure that it just work like that when across the cell.
If it is not a bug. close it please.

Thanks!
Comment 4 m.a.riosv 2015-12-19 15:37:28 UTC
Ok, I sse now.
Comment 5 QA Administrators 2017-01-03 19:46:55 UTC Comment hidden (obsolete)
Comment 6 Timur 2019-09-05 12:19:19 UTC
Steps:
1. Insert enters to come near bottom of the page in Writer
2. Insert a table which only have one cell.
3. Set no borders except bottom line.
4. Put some enters inside the table to go over the page bottom
5. Open Print preview and see 3 borders.
6. Open Table properties-Borders and see double border.
7. Try to remove only middle border, not possible.
8. With no-border, cannot add bottom border after.

Repro OO and 6.4+.
Comment 7 BogdanB 2020-09-28 16:02:33 UTC
Repro in
Version: 7.0.1.2
Build ID: 7cbcfc562f6eb6708b5ff7d7397325de9e764452
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded