Bug 96418 - Thumbnails of gallery are not generated properly when adding a new item
Summary: Thumbnails of gallery are not generated properly when adding a new item
Status: RESOLVED DUPLICATE of bug 98366
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Gallery
  Show dependency treegraph
 
Reported: 2015-12-11 16:13 UTC by wighou
Modified: 2016-05-11 11:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
gallery_creation (13.32 KB, application/vnd.oasis.opendocument.graphics)
2015-12-11 16:13 UTC, wighou
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wighou 2015-12-11 16:13:15 UTC
Created attachment 121228 [details]
gallery_creation

I created my own components and own gallery (Electronics analog) to make electronics schematic. But, when I add my new component to gallery (select 2 sec, drag and drop to gallery), the generated thumbnail in gallery, or does not appear or does not represent my component.
Comment 1 Buovjaga 2015-12-15 08:54:33 UTC
Reproduced.

In 5.2, I also see no thumbs for Symbols, Text shapes, most of the Arrows..

4.3 works ok.

Note to testers: https://help.libreoffice.org/Common/Adding_Graphics_to_the_Gallery
(The unintuitive drag'n'drop process might confuse testers)

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 917d59a84124d1022bd1912874e7a53c674784f1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-12_12:17:04
Locale: fi-FI (fi_FI)

4.3.0.1
Comment 2 raal 2015-12-15 21:58:04 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks
 4a101ce68b02931a5486f32d1eb7acddbd13268d is the first bad commit
commit 4a101ce68b02931a5486f32d1eb7acddbd13268d
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Jul 29 15:44:27 2015 -0700

    source d1046e7c3f66e5f3384ee1ef534ef28346702fc6

    source d1046e7c3f66e5f3384ee1ef534ef28346702fc6

:040000 040000 07bd313f6f25a8bae25c7a280af808d681e5e438 52b7bf3c6b75f3d67484ec37c9251c89f6951923 M      instdir

author	Caolán McNamara <caolanm@redhat.com>	2015-07-15 09:10:25 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2015-07-15 12:11:14 (GMT)
commit d1046e7c3f66e5f3384ee1ef534ef28346702fc6 (patch)

/bibisect-win32-5.1
$ git bisect log
# bad: [a2ca6bb70db1ba8f306a617d92070351d9a3a624] source 8b5182155b6d35a1be64d37136584e30ea6a6ef8
# good: [c1efd324c6ad448ac9edb030dc9738b9e6899e4d] source ab465b90f6c6da5595393a0ba73f33a1e71a2b65
git bisect start 'a2ca6bb70db1ba8f306a617d92070351d9a3a624' 'c1efd324c6ad448ac9edb030dc9738b9e6899e4d'
# bad: [1e602523875e23a7969d8c28276c82311eb2fa74] source 5b8e4f3d676eb0a026ce1eb4c1df2ec6e0736cb1
git bisect bad 1e602523875e23a7969d8c28276c82311eb2fa74
# bad: [1e602523875e23a7969d8c28276c82311eb2fa74] source 5b8e4f3d676eb0a026ce1eb4c1df2ec6e0736cb1
git bisect bad 1e602523875e23a7969d8c28276c82311eb2fa74
# good: [01eef57435e835a8bc484038bd81d1aa8a762920] source 064481201341d92af2ec1387bb53a9c4b480217f
git bisect good 01eef57435e835a8bc484038bd81d1aa8a762920
# bad: [6be5b8f118856a995c7d0c0db843167fbea1555d] source 69df701742a9c3946e2031488c377c18a5ec4de0
git bisect bad 6be5b8f118856a995c7d0c0db843167fbea1555d
# bad: [407159f8b3a4d483ad0952ab04de75fc78898852] source 71c6ee42d3311b31896e5a408d8f83f4e5d7726e
git bisect bad 407159f8b3a4d483ad0952ab04de75fc78898852
# good: [05c15e6999ee21f035066da19ea13bac9d1c7e99] source 74f9d9808fce14f015d56a2aaa4ec5616ed7aa3e
git bisect good 05c15e6999ee21f035066da19ea13bac9d1c7e99
# bad: [ac749ec5fe543c980afe169f14e1d19fafb58dca] source a9cf2cd5013a96ad1925cc9a1c56fc56b161ac8e
git bisect bad ac749ec5fe543c980afe169f14e1d19fafb58dca
# bad: [0b898e7eebdd3e09fb176feb3fdd5dc7febeb2c2] source d6790de07ff225f9e5b58152d01719e5fbe9e6cd
git bisect bad 0b898e7eebdd3e09fb176feb3fdd5dc7febeb2c2
# good: [1c8676d76769225cc94d34d74ec2975b31d55642] source dac1be92f22197c9e144ef36963547c46d12e77d
git bisect good 1c8676d76769225cc94d34d74ec2975b31d55642
# good: [7ffef5463176858a095fa35dda227770512920ad] source d0090009711cd323678e44323706faf72cba6b7d
git bisect good 7ffef5463176858a095fa35dda227770512920ad
# bad: [38843cc18b86fc0e7f9a48c52933f9936a6e0539] source 6de7d32df11efe35a3bb6b242ae6197f977af67a
git bisect bad 38843cc18b86fc0e7f9a48c52933f9936a6e0539
# good: [31dd6c7fd2ee1ca25bb254d1ce18faf879d999b1] source dffb58131f06fbe1aaeaa7b0d3ebe049d8384593
git bisect good 31dd6c7fd2ee1ca25bb254d1ce18faf879d999b1
# bad: [4a101ce68b02931a5486f32d1eb7acddbd13268d] source d1046e7c3f66e5f3384ee1ef534ef28346702fc6
git bisect bad 4a101ce68b02931a5486f32d1eb7acddbd13268d
# good: [01408893ffc11fbee6cd90dcc2e6d2ab679b4141] source 536051f8862203e0e115a5394a6379acd83cc8fe
git bisect good 01408893ffc11fbee6cd90dcc2e6d2ab679b4141
# first bad commit: [4a101ce68b02931a5486f32d1eb7acddbd13268d] source d1046e7c3f66e5f3384ee1ef534ef28346702fc6
Comment 3 Heiko Tietze 2016-05-04 14:58:57 UTC
Confirmed (a simple rectangle containing a diamond works, however).

Version: 5.2.0.0.alpha0+
Build ID: 6b232aeecc55f1715bc111e636e36a8e24827efb
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-26_07:40:04
Locale: de-DE (de_DE)
Comment 4 Caolán McNamara 2016-05-11 11:28:03 UTC

*** This bug has been marked as a duplicate of bug 98366 ***