Download it now!
Bug 96446 - Error in Help for LibreLogo
Summary: Error in Help for LibreLogo
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Travis Stewart
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: Help-Changes-Features
  Show dependency treegraph
 
Reported: 2015-12-12 16:52 UTC by Kolbjørn Stuestøl
Modified: 2020-10-20 10:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kolbjørn Stuestøl 2015-12-12 16:52:43 UTC
Help for LibreLogo (locale) Functions -> RANGE says:
   PRINT RANGE 10 ; print [0, 1, 2, 3, 4, 5, 6, 7, 8, 9]
   PRINT RANGE 3 10 ; print [3, 4, 5, 6, 7, 8, 9]
   PRINT RANGE 3 10 3 ; print [3, 6, 9]

In my version writing PRINT RANGE 10 outputs "range(0, 10", "range(3, 10" and "range(3, 10, 3" respectively.
To get the result as described in Help, I have to write PRINT LIST RANGE 10 etc.
 
Not tried in other versions of LibreOffice.
OS: Windows 7 and 8

Kolbjørn
Comment 1 Buovjaga 2015-12-16 11:20:50 UTC
I just get an error for both. How should I do it?
I tried

PRINT RANGE 10 ;
PRINT RANGE 10;
PRINT RANGE 10

and same for list range, but it doesn't seem to be a syntax error.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)
Comment 2 Gilvan Vilarim 2016-04-29 19:50:53 UTC
Hello. I confirm this in LibreOffice 5.1 on Windows, brazilian portuguese.

Best regards,
Gilvan.
Comment 3 George 2.0 Hope 2020-03-02 15:27:28 UTC
I can confirm, the documentation is still incorrect...

On Help Page:

 ○ https://help.libreoffice.org/6.4/en-US/text/swriter/librelogo/LibreLogo.html?DbPAR=WRITER

... it should state:

PRINT LIST RANGE 10 ; print [0, 1, 2, 3, 4, 5, 6, 7, 8, 9]
PRINT LIST RANGE 3 10 ; print [3, 4, 5, 6, 7, 8, 9]
PRINT LIST RANGE 3 10 3 ; print [3, 6, 9]

System Info:

Version: 6.3.5.2 (x64)
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Travis Stewart 2020-10-06 06:35:45 UTC
I submitted the patch in Gerrit, so this should be resolved once it is merged.
Comment 5 Buovjaga 2020-10-06 07:11:15 UTC
(In reply to Travis Stewart from comment #4)
> I submitted the patch in Gerrit, so this should be resolved once it is
> merged.

Patch: https://gerrit.libreoffice.org/c/help/+/103974

Travis: please
1. start the first line of the commit with tdf#96446
2. break the message up, so the first line has max. 72 characters and the other lines have max. 80
3. remove the actual bug link, because tdf#96446 will be linkified in our services automatically

https://wiki.documentfoundation.org/Development/gerrit/SubmitPatch#Submit_a_patch_for_review_with_gerrit
"please remember that the commit subject line should not be longer than 72 characters and the commit message lines, if any, should not be longer than 80 characters"
Comment 6 Travis Stewart 2020-10-06 07:24:53 UTC
Thanks for correcting that. I removed the direct link and added the short form to the beginning of the commit message. I think it now complies with the restrictions.
Comment 7 Commit Notification 2020-10-06 07:34:06 UTC
Travis Stewart committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/5494e02b2527f27a8cfbbd0a4a125443f3851715

tdf#96446 Fix Librelogo code example
Comment 8 László Németh 2020-10-20 10:18:08 UTC
Many thanks for reporting and fixing this! Likely it's worth to add the

FOR i IN RANGE 10 [ PRINT i ]

example in the future, showing an example without LIST.