Bug Hunting Session
Bug 96466 - missing data in PDF export from spreadsheet in Windows
Summary: missing data in PDF export from spreadsheet in Windows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: All Windows (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-12-13 21:33 UTC by Keith Herrington
Modified: 2016-05-26 10:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
pdf of ods file (51.70 KB, application/pdf)
2015-12-13 21:33 UTC, Keith Herrington
Details
ods for PDF creation (22.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-12-13 21:36 UTC, Keith Herrington
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Herrington 2015-12-13 21:33:08 UTC
Created attachment 121278 [details]
pdf of ods file

When I try to create a PDF from a spreadsheet either ODS, XLS XLSX documents all i get is a form PDF with no data in I have tryed all combinations in menu
Comment 1 Keith Herrington 2015-12-13 21:36:25 UTC
Created attachment 121279 [details]
ods for PDF creation
Comment 2 tommy27 2015-12-14 06:35:55 UTC
I confirm bug with LibO 5.0.3.1 and recent 5.2.0.0 daily build.

tested under Win8.1 x64

please tell your O/S as well
Comment 3 Keith Herrington 2015-12-14 07:27:09 UTC
Windows 10 64b

I last used it under Windows 7 32b
Comment 4 tommy27 2015-12-15 06:37:56 UTC
works fine in LibO 4.3.5 so it's a 4.4.x regression
bibisect needed

I rise importance to highest since there's data loss and affects a commonly used feature.

I put a Calc expert developer to CC list too.
Comment 5 Joel Madero 2015-12-19 16:04:47 UTC
Bodhi Moksha
LibreOffice Version: 5.2.0.0.alpha0+
Build ID: 5df326438fd3a5613a52b4de1935426911ff1301

Works fine.

You might want to try a daily build: http://dev-builds.libreoffice.org/daily/master/Win-x86_64@62-TDF/current/
Comment 6 tommy27 2015-12-19 19:14:24 UTC
still reproducible on Win8.1 x64 using 
LibO 5.2.0.0.alpha0+
Build ID: 014633f83e44ae8ba33087b6f38e8e253e281969
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-15_06:21:44
Locale: it-IT (it_IT)
Comment 7 Keith Herrington 2015-12-19 20:05:25 UTC
Version: 5.2.0.0.alpha0+ (x64)
Build ID: cfe08df695c046371c4361a434176e6381e3e064
CPU Threads: 2; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-12-15_13:10:55
Locale: en-GB (en_GB)

Tryed using above version but bug still exists
Comment 8 saurabhkukade 2016-01-21 17:33:14 UTC
Working fie on debian 8.2
Build ID: 7368803e540d530a157d3c4234ca5428a44cbc4a
Comment 9 tommy27 2016-01-22 06:20:39 UTC
yes, it seems a Windows only bug.
Comment 10 Timur 2016-01-29 12:11:23 UTC
I was free to add Justin due to the other PDF export bug. Be free to remove.
Comment 11 raal 2016-05-26 10:46:35 UTC
Hello, seems to be fixed in version  5.1.3.2. Please retest with  5.1.3.2,
https://www.libreoffice.org/download/libreoffice-fresh/

WFM  5.1.3.2,  5.2.0.0.alpha1+; win7
Comment 12 Timur 2016-05-26 10:59:20 UTC
Also in 5.0.6.