Download it now!
Bug 96480 - Crash with copy/cut (thus clip board use) from apparently corrupt paragraph(s) from specific doc
Summary: Crash with copy/cut (thus clip board use) from apparently corrupt paragraph(s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:5.2.0 target:5.1.0.2 target:5.0.5
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-12-14 11:35 UTC by Cor Nouws
Modified: 2016-10-25 19:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file where Copy a Par Does make LibreOffice Crash (24.18 KB, application/vnd.oasis.opendocument.text)
2015-12-14 11:36 UTC, Cor Nouws
Details
backtrace for 96480 (9.70 KB, text/x-log)
2015-12-16 11:09 UTC, Cor Nouws
Details
bt with debug symbols (9.34 KB, text/plain)
2015-12-19 16:53 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2015-12-14 11:35:15 UTC
Hi,

I'll attach a test document.
1. Open that.
2. put cursor behind "xx" on fist page
3. Press Shift+Down then Shift+End
   (first line on next page selected)
4. Cltr+C .. 
  > Kaboom

Found in version Version: 5.2.0.0.alpha0+
Build ID: d8c02ffd0f37c946e5a07f1062390714da26b8d0
Threads 2; Ver: Linux 4.2; Render: default; 

TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2015-12-10_23:40:47
Locale: nl-NL (nl_NL.UTF-8)

but also in older versions, e.g. 4.4.x
Comment 1 Cor Nouws 2015-12-14 11:36:57 UTC
Created attachment 121293 [details]
Test file where Copy a Par Does make LibreOffice Crash
Comment 2 Cor Nouws 2015-12-14 11:39:21 UTC
The document is a fraction of a document with a long history and forth and back editing in Word, Writer, Word and what more..
Comment 3 Cor Nouws 2015-12-16 11:09:21 UTC
Created attachment 121337 [details]
backtrace for 96480

Had to pkill soffice.bin. So I'm not sure if the backtrace is useful.
Comment 4 Julien Nabet 2015-12-19 16:53:54 UTC
Created attachment 121409 [details]
bt with debug symbols
Comment 5 Julien Nabet 2015-12-19 17:37:07 UTC
I submitted a patch to review:
https://gerrit.libreoffice.org/#/c/20821/
Comment 6 Commit Notification 2016-01-08 19:36:05 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=774fb6d2e7cf36b677e66c54278225b1256bd40f

tdf#96480: ODF import: eliminate duplicate cross reference heading bookmarks

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Michael Stahl (CIB) 2016-01-08 19:36:16 UTC
caused by 7c3c3006deaaaf1bb3f2f4eeeaf11da3bcebe53c

fixed on master
Comment 8 Julien Nabet 2016-01-08 20:32:32 UTC
My patch was just hiding the bug, thank you Michael for the real fix! :-)
Comment 9 Commit Notification 2016-01-11 10:32:45 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74c089fe14b82c796692b7600e78c8fea17e33cf&h=libreoffice-5-1

tdf#96480: ODF import: eliminate duplicate cross reference heading bookmarks

It will be available in 5.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-01-19 15:43:17 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=55d2301ac658167396bf5533c940bceffff67f04&h=libreoffice-5-0

tdf#96480: ODF import: eliminate duplicate cross reference heading bookmarks

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.