Bug 96493 - 3D slide transitions are not rendering
Summary: 3D slide transitions are not rendering
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-OpenGL
  Show dependency treegraph
 
Reported: 2015-12-14 19:57 UTC by V Stuart Foote
Modified: 2016-03-17 05:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-12-14 19:57:45 UTC
On builds of master (x86 on Windows from TB62) between 2015-12-08 and 2015-12-11 the 3D rendered transitions seem to have stopped displaying.  Either they are just too fast to perceive, or they are not actually redrawing the display.


=-ref-=
http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=6fd3f3caad1a559165dc9332249cbd0d84930775..6c68b71058263be74197a961fd7dfd2b43caf22d
Comment 1 Tomaz Vajngerl 2015-12-14 21:18:39 UTC
Which GPU and drivers do you have?
Comment 2 V Stuart Foote 2015-12-14 21:33:38 UTC
from OpenGL_device.log
=-=-=
DriverVersion: 10.18.13.5456
DriverDate: 12-3-2015
DeviceID: PCI\VEN_10DE&DEV_0FFE&SUBSYS_094C10DE&REV_A1
AdapterVendorID: 0x10de
AdapterDeviceID: 0x0ffe
AdapterSubsysID: 0x094c10de
DeviceKey: System\CurrentControlSet\Control\Video\{D058B8E7-F3B1-496D-B671-73BE9B73D07B}\0001
DeviceString: NVIDIA Quadro K2000
Comment 3 V Stuart Foote 2015-12-14 21:35:44 UTC
This hardware and driver--transitions render correctly with Windows 32-bit builds from TB62 trhough 2015-12-08, are bad starting with 2015-12-11 Windows 32-bit builds.  No TB build 9th or 10th
Comment 4 V Stuart Foote 2015-12-17 01:20:22 UTC
So this does also affect builds other than Windows

On Fedora 23 w/LXDE (as guest on VMWare Workstation 12 on Windows 8.1) and
Version: 5.2.0.0.alpha0+
Build ID: 8a342e9f6ad701bd46ecca1c3d270ef2d9670d44
CPU Threads: 1; OS Version: Linux 4.2; UI Render: GL; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-12-16_12:23:28
Locale: en-US (en_US.UTF-8)

No 3D slide transitions.  Unfortunately for this build, no opengl_device.log being written to settings/cache directory.
Comment 5 Timur 2016-02-23 08:05:31 UTC
Since I closed Bug 91583, is it related?
Comment 6 V Stuart Foote 2016-03-17 05:46:48 UTC
Might go back and identify the work on the GL transitions that cleared this at new year. But for now closing WFM.