Bug 96519 - bad file chooser without kde integration installed, bad taskbar icons with it installed
Summary: bad file chooser without kde integration installed, bad taskbar icons with it...
Status: RESOLVED DUPLICATE of bug 82598
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-15 19:26 UTC by JPJ
Modified: 2015-12-22 18:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
libreoffice application icons missing from taskbar (28.58 KB, image/png)
2015-12-15 19:26 UTC, JPJ
Details
file chooser when libobasis5.1-kde-integration is installed (54.54 KB, image/png)
2015-12-18 16:24 UTC, JPJ
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JPJ 2015-12-15 19:26:08 UTC
Created attachment 121320 [details]
libreoffice application icons missing from taskbar

This applies to LibreOffice 5.1 beta2, (that version is not listed in the bug creation form), both 5.1 beta2 from the pre-releases and this daily build running on Kubuntu 14.04.3 amd64.

Version: 5.1.0.0.beta2+
Build ID: 6d4d9cb5716ed452a5ff3f30c68203e2794c832f
Threads 4; Ver: 3.13; Render: default; 

If I install lodevbasis5.1-kde-integration, I end up with some really horrible file chooser.  This is neither the KDE file chooser nor the normal LibreOffice file chooser.

If I remove lodevbasis5.1-kde-integration, the file chooser goes back to the normal LibreOffice file chooser but the application icons normally associated with open documents in the taskbar are gone, replaced with the default X icon.
Comment 1 JPJ 2015-12-18 16:18:34 UTC
I have the same problem with LO 5.1 RC 1

Version: 5.1.0.1
Build ID: bcace328aabc4c8c10b56daa87da0a2ee6579b5a
Threads 4; Ver: Linux 3.13; Render: default; 

Locale: en-US (en_US.UTF-8)
Comment 2 JPJ 2015-12-18 16:24:53 UTC
Created attachment 121389 [details]
file chooser when libobasis5.1-kde-integration is installed
Comment 3 Buovjaga 2015-12-22 13:13:36 UTC
Hey, could you try with Kubuntu 15.10 in a VM to see, if the problem remains?
Apparently that older version you are using does not have certain patches.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided more information.
Comment 4 Maxim Monastirsky 2015-12-22 13:23:37 UTC

*** This bug has been marked as a duplicate of bug 82598 ***
Comment 5 JPJ 2015-12-22 18:44:58 UTC
I'm not sure this is a KDE bug or a duplicate because I don't have this issue in LibreOffice 5.0.x.
Comment 6 Maxim Monastirsky 2015-12-22 18:48:58 UTC
(In reply to JPJ from comment #5)
> I'm not sure this is a KDE bug or a duplicate because I don't have this
> issue in LibreOffice 5.0.x.
Upstream builds before 5.1 didn't have KDE4 integration (the *-kde-integration package *was* for KDE3), that's why you didn't see it before.