Download it now!
Bug 96559 - Convert Field/Chapter into StyleRef for Word
Summary: Convert Field/Chapter into StyleRef for Word
Status: RESOLVED DUPLICATE of bug 86790
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-17 15:35 UTC by Nicolas Saettel
Modified: 2016-02-20 15:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Saettel 2015-12-17 15:35:04 UTC
Hi,
I saw Bug 86790 where a styleref field in word is not supported in writer, the other way around would be really nice, i.e.

Inserting a Field & choosing Document/Chapter in a header (showing the chapter number and name of the chapter if style Title 1 is used, for example)
and
saving the document in a docx format would reproduce the result of doing :

Header and Footer Tools / Design / Field/ StyleRef -> Heading 1 in Word

Right now, the header shows "Chapter", no field

That would be a wonderful way to convince people to use libreoffice (I know it would be with my students in college)

Thanks
Nicolas
Comment 1 Buovjaga 2015-12-21 18:43:18 UTC
How is this different than the request in bug 86790?
Comment 2 Nicolas Saettel 2015-12-22 10:39:05 UTC
Hi Beluga,
Well, bug 86790 asks for support of the styleref from word to LO, I am asking for the other way around: I assumed the coding would be different, since the procedures are not the same, but I may be mistaken.
Thank you for your answer
Nicolas
Comment 3 Buovjaga 2015-12-22 11:21:23 UTC
(In reply to Nicolas Saettel from comment #2)
> Hi Beluga,
> Well, bug 86790 asks for support of the styleref from word to LO, I am
> asking for the other way around: I assumed the coding would be different,
> since the procedures are not the same, but I may be mistaken.
> Thank you for your answer
> Nicolas

Well the report says "This field can not currently be created in Writer", so I took it to mean that support inside Writer would be in the scope. Maybe you could ask in the report, if it was the idea?
Comment 4 Nicolas Saettel 2016-02-19 15:28:38 UTC
Thank you, I will ask
Comment 5 sebalis 2016-02-19 20:05:44 UTC
Are you’re wondering whether in bug 86790 I’m asking for Writer to fully support the STYLEREF field known from Word? The answer to that is yes, certainly. The chapter field is not flexible enough in my view.
Comment 6 Buovjaga 2016-02-20 14:17:49 UTC
Nicolas: do we set this as duplicate of bug 86790?
Comment 7 Nicolas Saettel 2016-02-20 15:07:11 UTC
Sebalis: thank you for the comment
Beluga: yes, let's set it as duplicate, since I included my comment in bug 86790
Thank you!
Comment 8 Buovjaga 2016-02-20 15:13:04 UTC

*** This bug has been marked as a duplicate of bug 86790 ***