Download it now!
Bug 96608 - different toolbar arrangement selection: simple vs complex
Summary: different toolbar arrangement selection: simple vs complex
Status: RESOLVED DUPLICATE of bug 92218
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-20 06:45 UTC by Ljiljan
Modified: 2016-03-22 07:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
BASIC toolbar style (100.51 KB, image/png)
2015-12-20 06:45 UTC, Ljiljan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2015-12-20 06:45:59 UTC
Created attachment 121418 [details]
BASIC toolbar style

This is just idea, not bug.

In order to improve visual appearance of LibreOffice, I have an relatively easy idea. In Options (or in menu View), users should be able to select "Simple" vs "Complex" toolbar style.

Simple toolbar style will include only one toolbar with most basic items (such as saving, PDF, some formatting item) while table and drawings toolbars will appear as usual. However, "more advance" or "complex" menu style will include standard + formatting toolbar + other toolbars LO developers agree. 

What do you think? Example of simple (or basic) toolbar style is attached. Some users prefer simple interface or they have smaller screen. Other users prefer lots of toolbars... this simple idea, combined with sidebar, could be even better than MS ribbons.
Comment 1 Heiko Tietze 2015-12-20 08:52:36 UTC
This idea is being ventialted in the design team. Actually, we want to support the various workflows and experiences of our users with the option to load/save and share different configurations. Read more in Samuel's blog post https://smehrbrodt.wordpress.com/2015/11/24/improving-the-toolbars-in-libreoffice/

Keep in mind that this concept is pre-alpha. It will not be implemented before LibO 6.0, I guess.
Comment 2 Ljiljan 2015-12-20 17:42:10 UTC
I really like the idea on this blog. I suggested long time ago something similar (https://bugs.documentfoundation.org/show_bug.cgi?id=80752), but idea/ approach suggested in a blog is much better.  

Anyway, this idea is a kind a different because it could introduce saving different toolbar configuration and allowing easy switch between "simple" (basic) and "advance" (more complex) toolbars. Then, it could be used in developing more flexible toolbar as described in blog? (https://smehrbrodt.wordpress.com/2015/11/24/improving-the-toolbars-in-libreoffice/)
Comment 3 slkleo 2015-12-25 12:56:09 UTC
Isn't this idea a duplicate of (or at least related to) the 'single toolbar' proposed in https://bugs.documentfoundation.org/show_bug.cgi?id=92218 ?
Comment 4 Ljiljan 2016-03-22 07:18:46 UTC

*** This bug has been marked as a duplicate of bug 92218 ***