Bug Hunting Session
Bug 96644 - Crash after Switch off of Header or Footer
Summary: Crash after Switch off of Header or Footer
Status: CLOSED DUPLICATE of bug 97051
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2015-12-21 13:30 UTC by Harald Koester
Modified: 2016-08-24 16:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-12-21 13:30:11 UTC
In order to reproduce:

[1] Open new text document.
[2] Switch on header: Format > Page > Footer > Select Header on, then OK
[3] Close document: File > Exit LibreOffice > Save > insert filename > Save. LibreOffice is closed.
[4] Restart LibreOffice and open document again.
[5] Switch off header: Format > Page > Header > Deselect Header on. A warning is displayed. Respond with Yes. Then OK.
[6]  Close document: File > Exit LibreOffice > Save. LibreOffice crashes, the dialogue “LibreOffice Document Recovery is displayed without any file name. Expected: Close without crash.
[7] Click OK. Sometimes the message “Unknown SEH Exception” is displayed.

Bug is similar to bug 91789. May be a dupe of bug 91789.

WORKSFORME with version 4.4.6. Hence regression.
Comment 1 raal 2015-12-21 16:32:27 UTC
This seems to have begun at the below commit.
Adding Cc: to Zolnai Tamás; Could you possibly take a look at this one? Thanks

20df21e49e0220ce241858cd154320dda3d03421 is the first bad commit
commit 20df21e49e0220ce241858cd154320dda3d03421
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Tue May 26 19:10:37 2015 -0500

    source sha:f7424ed710e54bb2437a28380b03ed7c26290edc

    source sha:f7424ed710e54bb2437a28380b03ed7c26290edc

:040000 040000 de9190f69bfb00d443e2ab72bba5a1db6230c100 d3552a3bf92402e8d0ccc44f51c3f52699685fae M      instdir

author	Zolnai Tamás <zolnaitamas2000@gmail.com>	2015-03-15 12:29:53 (GMT)
committer	Zolnai Tamás <zolnaitamas2000@gmail.com>	2015-03-16 23:10:01 (GMT)
commit	f7424ed710e54bb2437a28380b03ed7c26290edc (patch)
SfxTabDialog: avoid changing const input parameter
Comment 2 Björn Michaelsen 2016-02-03 23:56:31 UTC
Likely a dupe/same root cause as 97051. Please (re)check with a daily build of today or later as per https://bugs.documentfoundation.org/show_bug.cgi?id=97051#c13.
Comment 3 raal 2016-02-04 22:50:26 UTC
(In reply to Björn Michaelsen from comment #2)
> Likely a dupe/same root cause as 97051. Please (re)check with a daily build
> of today or later as per
> https://bugs.documentfoundation.org/show_bug.cgi?id=97051#c13.

No crash with Version: 5.2.0.0.alpha0+
Build ID: 91a7580e03d5b47c6e2513afce85ddee45e730b6
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-03_23:51:42

*** This bug has been marked as a duplicate of bug 97051 ***
Comment 4 Harald Koester 2016-08-24 16:26:29 UTC
Bug 97051 is closed, hence also this bug closed.