Download it now!
Bug 96674 - drawingML import: fully vertical lines are imported as horizontal ones
Summary: drawingML import: fully vertical lines are imported as horizontal ones
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.2.0 target:5.1.0.2 target:5...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-22 21:26 UTC by Miklos Vajna
Modified: 2018-07-03 10:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document (14.60 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-12-22 21:26 UTC, Miklos Vajna
Details
How it looks like currently (1.24 KB, image/png)
2015-12-22 21:27 UTC, Miklos Vajna
Details
How it should look like (1.20 KB, image/png)
2015-12-22 21:28 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2015-12-22 21:26:01 UTC
Created attachment 121505 [details]
Reproducer document

See the attached bugdoc, the vertical line is imported as a horizontal one. This worked in 4.2, as there the VML filter handles the zero-width/zero-height line special case, but since 4.3 we read the drawingML branch, which lacks support for this.
Comment 1 Miklos Vajna 2015-12-22 21:27:36 UTC
Created attachment 121506 [details]
How it looks like currently
Comment 2 Miklos Vajna 2015-12-22 21:28:08 UTC
Created attachment 121507 [details]
How it should look like
Comment 3 Commit Notification 2016-01-05 09:07:03 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=627c2469843c9461b665c4571f1214aca7fc36a4

tdf#96674 drawingML import: fix handling of zero width/height lines

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-01-08 20:29:17 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9be39a75053be54214efd1fc4c2811913659c30e&h=libreoffice-5-1

tdf#96674 drawingML import: fix handling of zero width/height lines

It will be available in 5.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-01-11 12:44:51 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5f4c528123d6c65b489ac18ab7892bc92866b09&h=libreoffice-5-0

tdf#96674 drawingML import: fix handling of zero width/height lines

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Armin Le Grand 2018-07-03 10:04:11 UTC
Removed with tdf#106792 -> no longer needed. Test kept, it can cry alarm if this gets bad again.