Download it now!
Bug 96676 - EMF+ not displaying correctly
Summary: EMF+ not displaying correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2015-12-23 02:44 UTC by Chris Sherlock
Modified: 2017-03-31 00:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
EMF with red filled triangle with black lines and green filled star with black lines (579.32 KB, image/x-emf)
2015-12-23 02:46 UTC, Chris Sherlock
Details
Differences between Word (correct) and LibreOffice (incorrect rendering) (2.19 MB, image/png)
2015-12-23 02:47 UTC, Chris Sherlock
Details
ODG file with imported EMF testcase (86.30 KB, application/vnd.oasis.opendocument.graphics)
2015-12-23 02:48 UTC, Chris Sherlock
Details
docx file with imported EMF testcase (101.62 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-12-23 02:49 UTC, Chris Sherlock
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Sherlock 2015-12-23 02:44:53 UTC
In fdo#77229 the EMF+ file with the red triangle and green star is not displaying correctly in LibreOffice. Instead, we get:

- With the red triangle: 
  + on the far left side the black line is too thick
  + the black line is not black, but grey
  + the red fill should be an intense red, but instead shows as a very light red

- the green star does not show at all

Test cases will be attached.
Comment 1 Chris Sherlock 2015-12-23 02:46:37 UTC
Created attachment 121509 [details]
EMF with red filled triangle with black lines and green filled star with black lines

The EMF from bug 77229.
Comment 2 Chris Sherlock 2015-12-23 02:47:47 UTC
Created attachment 121510 [details]
Differences between Word (correct) and LibreOffice (incorrect rendering)

On OS X
Comment 3 Chris Sherlock 2015-12-23 02:48:35 UTC
Created attachment 121511 [details]
ODG file with imported EMF testcase
Comment 4 Chris Sherlock 2015-12-23 02:49:23 UTC
Created attachment 121512 [details]
docx file with imported EMF testcase

Inserted via Word 2014 on OS X
Comment 5 Alex Thurgood 2015-12-23 16:33:47 UTC
Confirming :

On LO 5032, the star is nowhere to be seen if the EMF file is opened directly with LibreOffice (it opens by default in Draw), only a pale red triangle as Chris has described appears.

On Word for Mac 15.17.1 (latest official release), I see a deep red triangle with thick black borders and a green star side by side in the docx file.
Comment 6 Guillaume Smaha 2016-05-23 13:40:41 UTC
Can't reproduce on LibreOffice 5.1.2.2 (Ubuntu 16.04 x64)
Comment 7 Guillaume Smaha 2016-05-23 14:30:43 UTC
Reproductible on Windows x64 with
LibreOffice 5.2.0.0.alpha1 (x86)
BuildID : a75aa73b2bf793faac1adb3b5f67e09d252d5fe9

The both images don't appear.

But, if I start LibreOffice with the env variable EMF_PLUS_DISABLE=true, the images are correctly displayed.
Comment 8 Bartosz 2017-03-30 20:59:31 UTC
Unable to reproduce with LibreOffice 5.3.1 (Windows XP)

I dragged emf file into Writer document and I opened attached docx document.
In both cases it is displaying correctly
Comment 9 V Stuart Foote 2017-03-31 00:59:40 UTC
Confirming the WFM on Windows 10 Home with
Version: 5.3.2.0.0+ (x64)
Build ID: c8f0a37ff804e6329b21a4b7bfabb0667263c6e5
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

both OpenGL and Default rendering of the EMF+ appears correct.