Download it now!
Bug 96751 - EDITING writer hangs when editing an image in a docx file
Summary: EDITING writer hangs when editing an image in a docx file
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
Keywords: bibisected, bisected, filter:docx, regression
: 104166 104553 (view as bug list)
Depends on:
Blocks: Anchor-and-Text-Wrap DOCX-Images File-Opening
  Show dependency treegraph
Reported: 2015-12-28 21:09 UTC by doriano.mag
Modified: 2020-05-24 10:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

This is the buggy file. I received it, so I do not know which version of msWord was used to create it. (84.17 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-12-28 21:09 UTC, doriano.mag

Note You need to log in before you can comment on or make changes to this bug.
Description doriano.mag 2015-12-28 21:09:32 UTC
Created attachment 121586 [details]
This is the buggy file. I received it, so I do not know which version of msWord was used to create it.

When I select the image on the attached file, and try to apply 

Format > Wrap > None

the page counter on the bottom left start to grow out of control and finally Writer hangs.

the same happens when clicking the correspondent button on the toolbar.

Reproducible: every time
Comment 1 Buovjaga 2015-12-29 19:19:58 UTC
No problem in 5.0.4.

However, 5.1 RC1 & 5.2 hang on opening the file (unable to get a backtrace).

I'll set this to NEW.

Win 7 Pro 64-bit, Version: (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: fi-FI (fi_FI)

Build ID: a4764cfa80270f973da5861d0ddc28298bf16f4d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-24_22:45:12
Locale: fi-FI (fi_FI) 64-bit
Comment 2 MM 2015-12-29 22:51:54 UTC
(In reply to Beluga from comment #1)
> No problem in 5.0.4.

Confirmed with v5.0.4.2 under ubuntu 14.04 x64.
Confirmed with v4.4.7.2 under windows 7 x64.

To reproduce, open the file, click on the picture one time. Then RMB > wrap > No wrap.
The page counter goes on and on (>1000).
If you set page footer off and try it again, then the picture is simply moved to another page, but the page counter doesn't go crazy anymore and the program doesn't hang.

> However, 5.1 RC1 & 5.2 hang on opening the file (unable to get a backtrace).

That's another problem. Confirmed with v5.1.0.1 under ubuntu 14.04 x64.
Comment 3 Mike Kaganski 2016-12-19 20:45:10 UTC
*** Bug 104166 has been marked as a duplicate of this bug. ***
Comment 4 Mike Kaganski 2016-12-19 22:50:06 UTC

$ git bisect log
# bad: [05d11632892a322664fb52bac90b2598b7fb7544] source sha:5616d22b57a9a5e57d545e912e029162a230829b
# good: [c1efd324c6ad448ac9edb030dc9738b9e6899e4d] source sha:ab465b90f6c6da5595393a0ba73f33a1e71a2b65
git bisect start 'master' 'oldest'
# bad: [97526ab777da7e58ce283c05498262ecdd4d6f7f] source sha:4ea70f87f7a2b61eda6e5ab1f48debf6fcfadc1f
git bisect bad 97526ab777da7e58ce283c05498262ecdd4d6f7f
# bad: [2202cdaa0eae3f646f1285a0ea45934edeb26e8a] source sha:a88bf8fd10c42a15e5d6e66da656889c82b4933a
git bisect bad 2202cdaa0eae3f646f1285a0ea45934edeb26e8a
# bad: [1d0a95445c203c11beb1aa5eae844cf178ea0984] source sha:8f324aebfb94c4b2023894121b954ad4f35eb395
git bisect bad 1d0a95445c203c11beb1aa5eae844cf178ea0984
# good: [fb2523235c0a0c37d4e1f482afde48066f2c4b83] source sha:5b87ff40857147bee697a9bf420aae89e8cd9e93
git bisect good fb2523235c0a0c37d4e1f482afde48066f2c4b83
# good: [96c5e6142c03cdfdd63c936de319666d0fdcffcc] source sha:b2c8ea3a0253ce87f1b292fbb19b461a53c14912
git bisect good 96c5e6142c03cdfdd63c936de319666d0fdcffcc
# bad: [5873f9d01f7cd324630121b0e318ae65fd26e597] source sha:4897f10beab678494a7c2dfdc140c424154e9f8c
git bisect bad 5873f9d01f7cd324630121b0e318ae65fd26e597
# good: [b300e23d1d05e6d3ecae25e335bd156dca158aed] source sha:e1323281875e3937c812a2e172fd75d16a573fd0
git bisect good b300e23d1d05e6d3ecae25e335bd156dca158aed
# bad: [488e1a7b0f973b2bbf3f0f647dd42619830a7ea8] source sha:e966e9fae635afe6237738a83658baf7c86eea93
git bisect bad 488e1a7b0f973b2bbf3f0f647dd42619830a7ea8
# good: [a25ff76f4736e0889dba4958b6eafccaeed86410] source sha:0f2007b11b4a0b39bc4e67ade30961f0d533474a
git bisect good a25ff76f4736e0889dba4958b6eafccaeed86410
# good: [7a5533a35ae75b9e6ac247ad3de8a87dfc30909e] source sha:366eae3ad3ed97fc2637066c8a0c66ae0db32ed6
git bisect good 7a5533a35ae75b9e6ac247ad3de8a87dfc30909e
# good: [02f5d37b76714e195776cf7a5f2bc441ea9878e0] source sha:eacbead4f5a4dc7c8db3d60c948e28c199aa2b10
git bisect good 02f5d37b76714e195776cf7a5f2bc441ea9878e0
# bad: [cfbb9043a9166c0850d296f61c3437b97ddaeaf8] source sha:6a55792cdd39f95c28a929cd0c1c1a3e89e00cfd
git bisect bad cfbb9043a9166c0850d296f61c3437b97ddaeaf8
# good: [c114ea3550a9dc5b7f1efddbf8440e3cf54db8b1] source sha:753fa7ca2fbeb6dfc3f014a68c7d48c6e227be34
git bisect good c114ea3550a9dc5b7f1efddbf8440e3cf54db8b1
# first bad commit: [cfbb9043a9166c0850d296f61c3437b97ddaeaf8] source sha:6a55792cdd39f95c28a929cd0c1c1a3e89e00cfd

author	Caolán McNamara <>	2015-06-09 12:44:56 (GMT)
committer	Caolán McNamara <>	2015-06-09 13:41:19 (GMT)
commit	6a55792cdd39f95c28a929cd0c1c1a3e89e00cfd
tree	39d3ae9491e33043845c535dbbdc5bb2af57c2ef
parent	753fa7ca2fbeb6dfc3f014a68c7d48c6e227be34
Revert "restore "crash on layout of novell622972-2.html" temporarily"
Comment 5 Xisco Faulí 2016-12-19 22:51:35 UTC Comment hidden (obsolete)
Comment 6 Mike Kaganski 2016-12-21 07:47:24 UTC
Just to clarify:

the layout loop problem was fixed with commit 9857c6390212e16dd9f26b47b4afc5d33b5242ef, and it worked OK for Then, it was reverted in commits 64dc505ce180a168798b725423a308207de42c63 (for branch 'libreoffice-5-0') and dfedebd1e1912252bc2b5204a2b5371952b552cd (for master), so it already didn't work for 5.0.RC1+. Then, for 5.1, it worked again between 46a76be3a13ad501e4d09da652f551b2c621e685 and 6a55792cdd39f95c28a929cd0c1c1a3e89e00cfd.
Comment 7 Xisco Faulí 2017-10-28 18:20:52 UTC
*** Bug 104553 has been marked as a duplicate of this bug. ***
Comment 8 Caolán McNamara 2017-11-16 14:39:04 UTC
Yeah, but 9857c6390212e16dd9f26b47b4afc5d33b5242ef caused bug 91695 so there isn't a known magic bullet to fix this document without making that happen again
Comment 9 Caolán McNamara 2017-11-16 16:49:32 UTC
looks like CalcContent is the looping thing
Comment 10 QA Administrators 2018-11-17 03:46:47 UTC Comment hidden (obsolete)
Comment 11 doriano.mag 2018-11-24 17:17:42 UTC
The bug is still present in version (x64)
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
Comment 12 QA Administrators 2019-11-25 03:31:12 UTC
Dear doriano.mag,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat:

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team