Download it now!
Bug 96754 - OSX: CALC and IMPRESS preview icons not working in Finder quicklook function
Summary: OSX: CALC and IMPRESS preview icons not working in Finder quicklook function
Status: RESOLVED DUPLICATE of bug 35361
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.3.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-29 07:15 UTC by Fred
Modified: 2017-11-10 20:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of OSX preview icons (115.41 KB, image/jpeg)
2015-12-29 07:15 UTC, Fred
Details
ODT-finder (56.64 KB, image/png)
2016-02-08 19:46 UTC, Alex
Details
ODS-finder (118.04 KB, image/png)
2016-02-08 19:47 UTC, Alex
Details
ODT-quicklook (35.22 KB, image/png)
2016-02-08 19:47 UTC, Alex
Details
ODS-quicklook (313.79 KB, image/png)
2016-02-08 19:47 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fred 2015-12-29 07:15:56 UTC
Created attachment 121587 [details]
Screenshots of OSX preview icons

In OSX, files have preview icons which give you a rough visual idea what is in them.  LibreOffice files support this too, with the exception of CALC and IMPRESS (see attached) which makes a generic search somewhat complicated (originally I thought it was only CALC as I rarely use Impress, but a quick check showed that Impress has the same issue).

LibreOffice /Writer/ previews work fine (see screenshots).

Could someone else on OSX please check if it's just me or indeed a LibreOffice issue?

Thanks!
Comment 1 Robert Großkopf 2015-12-29 10:36:46 UTC
Changed component to UI - isn't a database-Problem (BASE).
Comment 2 Alex Thurgood 2015-12-30 09:08:45 UTC
Confirmed with LO 5032, OSX 10.11.2
Comment 3 Alex Thurgood 2015-12-30 09:09:50 UTC
Have set version to 5032, but problem goes back much further
Comment 4 Alex 2016-02-08 19:45:44 UTC
I'd like to point out that this has recently been marked "worksforme", see here: https://bugs.documentfoundation.org/show_bug.cgi?id=35361
The claim was that it works on new OS 10.11, but not the old OS mentioned by OP, 10.6. However it doesn't seem to work at all except for ODT files. 

Should also be noted that this applies not only to document icons, but Quick Look itself in finder and the popup you get when you hit space with the file selected. Adding images to show what I'm talking about for ODS vs ODT files.
Comment 5 Alex 2016-02-08 19:46:44 UTC
Created attachment 122452 [details]
ODT-finder
Comment 6 Alex 2016-02-08 19:47:02 UTC
Created attachment 122453 [details]
ODS-finder
Comment 7 Alex 2016-02-08 19:47:37 UTC
Created attachment 122454 [details]
ODT-quicklook
Comment 8 Alex 2016-02-08 19:47:57 UTC
Created attachment 122455 [details]
ODS-quicklook
Comment 9 Alex 2016-02-08 19:49:53 UTC
Also, steve noted in the other thread that Apple added functionality for open document files, but as demonstrated I don't see it besides for ODT. Is there a LO plugin overriding the Apple plugin and not working maybe?
Comment 10 bubu 2016-03-03 22:44:14 UTC
Hi,

I reopened bug #35361

https://bugs.documentfoundation.org/show_bug.cgi?id=35361

Regards
Comment 11 QA Administrators 2017-03-06 15:27:20 UTC Comment hidden (obsolete)
Comment 12 eisa01 2017-11-10 20:07:39 UTC
This is a duplicate. LibreOffice doesn't currently bundle any Quicklook plugins, the ODT is handled by the OS plugin

qlmanage -m plugins | grep oasis
  org.oasis-open.opendocument.text -> /System/Library/QuickLook/Text.qlgenerator (720.7)

*** This bug has been marked as a duplicate of bug 35361 ***