Bug 96905 - OOXML Word document fails to open in newer versions
Summary: OOXML Word document fails to open in newer versions
Status: RESOLVED DUPLICATE of bug 92157
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-05 10:19 UTC by Jeroen Hoek
Modified: 2016-01-05 13:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document: opening fails in 5.0.2.2. (77.75 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-01-05 10:19 UTC, Jeroen Hoek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Hoek 2016-01-05 10:19:47 UTC
Created attachment 121727 [details]
Sample document: opening fails in 5.0.2.2.

The Dutch government published a position paper on their official website as OOXML DOCX. LibreOffice crashes with the following error on opening:

File format error found at 
  SAXParseException: '[word/document.xml line 2]: unknown error', Stream 'word/document.xml', Line 2, Column 30060(row,col).

Two users on Hacker News report that they *can* open this document in LibreOffice 4.2.4.2 and 4.2.8.2.

This bug seems similar to the regression reported in #95071, but the issue persists in dev-build 5.1.0.1.0.
Comment 1 Cor Nouws 2016-01-05 13:06:15 UTC
Hi Jeroen,

Thanks for reporting. Hurray for our government's use of standards ;)

Apart from that: looking at https://bugs.documentfoundation.org/show_bug.cgi?id=92157#c1 and the initial report, I think this is a duplicate of bug 92157.
Marking as such now.

*** This bug has been marked as a duplicate of bug 92157 ***