Bug 96910 - EDITING - Crashs using "insert column left" for large documents with concatenation
Summary: EDITING - Crashs using "insert column left" for large documents with concaten...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Yogesh Desai
URL:
Whiteboard: target:5.2.0 target:5.1.1 target:5.0.6
Keywords: haveBacktrace, regression
: 94841 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-05 17:27 UTC by Arno
Modified: 2016-10-25 19:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Setup for "Insert columns left" crash (6.25 MB, application/vnd.oasis.opendocument.spreadsheet)
2016-01-05 17:27 UTC, Arno
Details
backtrace from last throw and catch operations (15.84 KB, text/plain)
2016-01-06 03:48 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arno 2016-01-05 17:27:14 UTC
Created attachment 121732 [details]
Setup for "Insert columns left" crash

In my simplified test I created a Calc-document with 3 columns and a lot of rows; testet with 1048576 rows. This is the amount of rows which will be filled, when I select a whole column and paste some cell-data).
The first and second column contain some arbitary text-data. The third column contains the formula for concatenating column A and B like =CONCATENATE(A1;B1) for the first cell of C.

With this setup I have selected column B and clicked on "Insert columns left".
Calc crashed with the following fatal error:
multi_type_vector::get_block_position#676: block position not found! (logical pos=1048576, block size=1, logical size=1048576)

The attachment contains my testfile with the setup described above.
Comment 1 m.a.riosv 2016-01-05 22:32:33 UTC
Hi @Arno, thanks fore reporting.

Reproducible.
Win10x64
Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78

last working:
Versión: 4.1.6.2
Id. de compilación: 40ff705089295be5be0aae9b15123f687c05b0a

With
Versión: 4.2.8.2
Id. de compilación: 48d50dbfc06349262c9d50868e5c1f630a573ebd
doesn't insert the column.

First crashing.
Versión: 4.3.7.2
Id. de compilación: 8a35821d8636a03b8bf4e15b48f59794652c68ba

Please @Arno, don't set up as NEW your own reports, the usual way is someone else doing that after reproduce the problem.
Comment 2 MM 2016-01-05 23:28:33 UTC
Also crashes with v4.2.8.2 under mint 17.3 x64.
First crash for me is V4.2.6.3 Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21 with errormsg: "Block position not found!"
Comment 3 Terrence Enger 2016-01-06 00:27:15 UTC
Thank you, Arno, for helping us to improve LibreOffice.

In the way we use bugzilla, bug status NEW means that somebody beside
the reporter has managed to reproduce the problem and has searched for
potential duplicate bug reports.  However, my observations are
sufficient to confirm the bug.

Some observations ...

(*) linux daily dbgutil bibisect version 2016-01-05 just quits without
    a core file.  The terminal output has nothing very interesting.

(*) I created a .odt with just row 1048576.  The same version of
    LibreOffice inserted a column without problem.

(*) linux daily dbgutil bibisect version 2015-05-20 issues the message
    which Arno quoted.  Upon <OK> the program quit without a core
    file.  The terminal output has nothing very interesting.

(*) A local build of commit 93b3199 running under gdb reported SIGSEGV
    as the program was trying to display the message box.  I have
    filed bug 96913 for this latter failure.
Comment 4 Terrence Enger 2016-01-06 03:48:13 UTC
Created attachment 121744 [details]
backtrace from last throw and catch operations

The program is LibreOffice commit 9eb3199, fetched 2015-01-05 02:58
UTC, configured ...

    CC=ccache /usr/bin/gcc
    CXX=ccache /usr/bin/g++
    --enable-option-checking=fatal
    --enable-dbgutil
    --enable-debug
    --enable-crashdump
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
    # --disable-remote

..., built and running on debian-stretch.

I am setting keyword have-backtrace.
Comment 5 Yogesh Desai 2016-01-22 06:42:12 UTC
I have submitted a patch.

gerrit link:
https://gerrit.libreoffice.org/#/c/21661/
Comment 6 Commit Notification 2016-01-25 09:53:06 UTC
Yogesh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=208883398dcf9af6b88611097d1f75d5fbc9afad

tdf#96910 : Calc crashes while using "Insert Column Left" for large Documents

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-01-25 14:22:32 UTC
Yogesh committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=509a189bf70370fbd09f3bb962f8b4e9eacbc6d1&h=libreoffice-5-1

tdf#96910 : Calc crashes while using "Insert Column Left" for large Documents

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2016-01-25 14:32:34 UTC
Yogesh committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=10f3272bb1bf36cae5eb6e80f9f1e0f4753ebb5d&h=libreoffice-5-0

tdf#96910 : Calc crashes while using "Insert Column Left" for large Documents

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Terrence Enger 2016-04-03 01:13:33 UTC
I see the problem fixed in daily Linux dbgutil repository version
2016-04-02.  Thank you, Yogesh.

Arno,

When you see the problem fixed, please set the bug status to CONFIRMED FIXED.
Comment 10 Caolán McNamara 2016-06-02 16:50:29 UTC
*** Bug 94841 has been marked as a duplicate of this bug. ***