Bug 96990 - Default document language is not used as default in cell formatting
Summary: Default document language is not used as default in cell formatting
Status: RESOLVED DUPLICATE of bug 96988
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-09 19:13 UTC by teo8976
Modified: 2016-01-10 01:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description teo8976 2016-01-09 19:13:22 UTC
Steps to reproduce:
1 - create a new document
2 - go to Tools->Options->Language Settings -> Languages
3 - In "Default language for documents", select "Spanish" (or whatever language you like that is not the language of your system), check the "Apply to current document only" checkbox and save.

(optional steps: save the document, close LO, reopen the document - the result will be the same)

4 - Then pick a cell in the document that has never been touched and do "Format cells".

Expected: since the default language for this document is Spanish, the selected language for any formatting (number, date, etc) should be Spanish, until I change it.

Observed: in Format Cells, US English is still selected by default. So I wonder what the "language for the document" has been applied to. It should be applied by default to EVERYTHING in this document.

Also note: if I select Spanish as the default language for documents (WITHOUT checking the "current document only" checkbox) and then create a fresh new document, the outcome will be the same.


My system is in English and I want it that way, but if I create a document whose language is Spanish, everything in that document should default to Spanish.
Comment 1 m.a.riosv 2016-01-09 19:49:10 UTC
Menu/Tools/Options/Language Settings/Language Of - Locale settings, set up the language for cell styles, also changing the language in cell's 'Default Style' 'Numbers' tab, has the same effect. 

Menu/Tools/Options/Language Settings/Default Languages for Documents, set up the text language, changing the language in cell's Default Style 'Font' tab, has the same effect.

So there is a lot of flexibility on how to use a mix of languages in the spreadsheets.

https://wiki.documentfoundation.org/Documentation/Publications
Sometimes it's better take some lessons before giving them.
Comment 2 teo8976 2016-01-09 23:18:15 UTC
1) That should be made much clearer. How is one supposed to know that "locale settings" apply to cell formatting while "language for the document" applies to something else? As it is now, it's completely obscure. One can only guess and try and see what happens.

2) Does the checkbox "for the current document only" apply also to the "Language of" part on the top?

=> If it doesn't (as it looks like by the UI layout): then this is no solution at all. I shouldn't have to change my locale settings every time I switch to a document which is in a different language. This setting MUST be per-document.

=> If it does: then the design of this UI is terrible. The checkbox looks like it belongs to the section titled "Default language for documents". And also, what said in issue #96988 applies here: if these are setting that are (or can be) applied to the document, they should be in File/Properties.

Either way, figuring out how to properly set the language for a document is a nightmare.

And
3) Flexibility is good (it is a must indeed), but by DEFAULT you should be able to have EVERYTHING in a document switch to a given language with one action: then the more you are able to tune the better, but if I want to start out a document in Turkish (while I usually write in English), I cannot have to search for half a dozen places where I need to switch to Turkish.
Comment 3 m.a.riosv 2016-01-10 01:27:39 UTC
How many other options (there are hundreds) must obvious for you?
What obvious means?, 

What it's obvious that is no possible,a program like LibreOffice without certain level of complexity.
 
The majority of the options are in the Menu/Tools/Options, have you given yourself the time to review these options, looking at the help for those most interesting for you.
Have you had at least a quick read of the help?

What is the bug?

In any case a duplicate.

*** This bug has been marked as a duplicate of bug 96988 ***