Bug Hunting Session
Bug 96997 - Sidebar usability and screen space
Summary: Sidebar usability and screen space
Status: RESOLVED DUPLICATE of bug 85905
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2016-01-10 05:53 UTC by john
Modified: 2016-10-24 16:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2016-01-10 05:53:16 UTC
The new sidebar (LO 4.4.72) is nice for a particular way of using the screen, but it seems to have messed up my preferred configuration, which is to have the Styles and Navigator both docked on the left-side, one above the other.

Firstly, the sidebar itself uses quite a bit of horizontal screen space. Once I have these two panels docked, I basically never want to use the sidebar, so I would like to have the option of making it disappear. But I can't see a way to do that. Also, the screen is a bit messy, because one of the panels gets a sidebar, and the other doesn't.

Perhaps an improved approach would be allow a *multi-panel* sidebar:
* one button at top of sidebar to hide the sidebar -- while *keeping* the visible panel(s) visible; a menu option or key could be used to unhide the sidebar icons.
* another button on the sidebar to turn on/off *multi-panel view*. in this mode, clicking a sidebar icon would *add or remove* extra panels stacked next to the sidebar, instead of *switching* the panels. A bit like expand/collapse 'twisties' eg in a file folder view.

I think that this revision would be quite powerful; it allows people who want to have several panels stacked next to the sidebar, and it also preserves the new behaviour for people who like it, and also allows the previous sidebarless behaviour since the sidebar can be hidden permanently if the user desires.
Comment 1 Joel Madero 2016-01-10 07:00:27 UTC
Punting to UX team.
Comment 2 V Stuart Foote 2016-01-10 14:17:36 UTC
Functionally a duplicate of bug 85905, please read discussion there--but equally review bug 33223 and linkages from meta bug 65138

*** This bug has been marked as a duplicate of bug 85905 ***