The "new" gbuild build system is picking up some age -- and some things bitrot.
Initially gbuild had all its variables prefixed/namespaced with gb_... unless this was unavoidable. The rationale is that gb_ is not a lot to write extra and this:
- prevents conflicts with shell environment variables, and thus prevents:
-- conflicts with any of the tools using the environment in the build
-- conflicts with environment vars from the users shell bleeding into the build
- is more grep-able
So unless there are very, very good reasons (like an external tool we are using in the build being hardcoded to a variable name) for a build system variable not to start with a gb_ prefix, it should. As a bonus, the var should ideally continue showing what part of the build system it belongs to (e.g. gb_CppunitTest_... or gb_Jar_...) to avoid hard to debug overlaps there as we are unfortunately in a project global namespace.
Code pointer: solenv/gbuild/
JanI is default CC for Easy Hacks (Add Jan; remove LibreOffice Dev List from CC)