Bug 97091 - FILEOPEN: particular .svg (exported from .odg) renders text invisible importing
Summary: FILEOPEN: particular .svg (exported from .odg) renders text invisible importing
Status: RESOLVED DUPLICATE of bug 32248
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2016-01-13 05:47 UTC by Christopher M. Penalver
Modified: 2018-06-20 17:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
p0p1p2.odg (46.31 KB, application/vnd.oasis.opendocument.graphics)
2016-01-13 05:47 UTC, Christopher M. Penalver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2016-01-13 05:47:15 UTC
Created attachment 121893 [details]
p0p1p2.odg

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/138141

OOo bug may be found at:
http://openoffice.org/bugzilla/show_bug.cgi?id=52605

apt-cache policy libreoffice-draw
libreoffice-draw:
  Installed: 1:5.0.2-0ubuntu1
  Candidate: 1:5.0.2-0ubuntu1
  Version table:
 *** 1:5.0.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status

What is expected to happen in Draw via a terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/138141/+attachment/2144240/+files/p0p1p2.odg

open the file > export to svg > open the svg in Draw and the two files should look the same.

What happen instead is the text is gone in the p0p1p2.svg file. The problem is that in the svg file the 'fill' attribute of the text is set to 'none' while it should have the color of the text.

WORKAROUND: replace fill:none with fill:#000000 in the xml code of the svg file and text will be rendered black. Until bug is solved, users can do this with a replace all command in a text editor.
Comment 1 V Stuart Foote 2016-06-26 03:33:22 UTC
No issue with export to SVG filter, issue with SVG import filter. Workaround would have been using the svgio filter using Insert -> Image

Resolved with bug 32248.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc3eb865bd10e690dbf80f41277b062ac2253572

tdf#32248 SVG: first attempt to support tspan elements

It will be available in 5.2.0.

*** This bug has been marked as a duplicate of bug 32248 ***