Bug Hunting Session
Bug 97100 - Incorrect French translation in Compress image dialog
Summary: Incorrect French translation in Compress image dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: medium normal
Assignee: Jean-Baptiste Faure
URL:
Whiteboard:
Keywords:
Depends on: 97192
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-13 12:55 UTC by Milan Bouchet-Valat
Modified: 2016-01-17 16:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Bouchet-Valat 2016-01-13 12:55:28 UTC
In the "Compress image" dialog (right click on an image in Writer -> Compress image), the string "Afficher la taille" is obviously wrong in French. Without checking, I guess it's a translation of "Display size", and I think it should be "Taille d'affichage".

I also wonder whether "Qualité de l'image" et "Nouvelle qualité" are correct. Looks like this should be "Taille de l'image" and "Nouvelle taille" (i.e. "Image size" and "New size").

Finally, "Réduire la résolution des images" should probably be singular, as the settings only affect the currently selected one.
Comment 1 Julien Nabet 2016-01-13 19:20:08 UTC
On pc Debian x86-64 with master sources updated today or with LO Debian package 5.0.4.2 + French UI, I don't reproduce this for Compress Image (didn't test the rest).

On which env are you? (Linux, Windows, MacOs)
Comment 2 Milan Bouchet-Valat 2016-01-14 11:01:49 UTC
I'm on Fedora with LO 5.0.4.2-3.fc23.

All the issues I've reported are in the Compress image dialog, so you should be able to confirm/infirm all of them at the same time. What strings do you see?
Comment 3 Julien Nabet 2016-01-16 15:17:23 UTC
Sorry Milan, I had misunderstood your description. I could reproduce this on master sources updated yesterday.

Here are the strings (English (keycode) -> French):
"View size" (K6omq)-> "Afficher la taille"
"Image capacity" (W4Aic) -> "Qualité de l'image"
"New capacity" (DDGuD) -> "Nouvelle qualité"

Sophie/Jean-Baptiste: thought you might be interested in this one.
Comment 4 Julien Nabet 2016-01-16 15:27:24 UTC
Strings come from compressgraphicdialog.ui, see
http://opengrok.libreoffice.org/xref/core/svx/uiconfig/ui/compressgraphicdialog.ui#516
Comment 5 Jean-Baptiste Faure 2016-01-16 16:12:46 UTC
Thank you for reporting. I will do the correction.

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2016-01-16 16:21:57 UTC
Done for 5.0. and master (5.1 and next) :

"View size" (K6omq)-> "Taille d'affichage"
"Image capacity" (W4Aic) -> "Poids de l'image"
"New capacity" (DDGuD) -> "Nouveau poids"

Best regards. JBF
Comment 7 Milan Bouchet-Valat 2016-01-16 17:17:52 UTC
Thanks!

Admittedly, the English phrasing "image capacity" is unusual too. "Capacity" refers to a storage ability, not to the share of that storage occupied by a file.
Comment 8 Julien Nabet 2016-01-16 17:46:06 UTC
(In reply to Milan Bouchet-Valat from comment #7)
> Thanks!
> 
> Admittedly, the English phrasing "image capacity" is unusual too. "Capacity"
> refers to a storage ability, not to the share of that storage occupied by a
> file.

I agree you Milan, let's ask to ux-team.


Thank you Jean-Baptiste for your very quick fix! :-)
Comment 9 Heiko Tietze 2016-01-16 18:01:02 UTC
I would call it "size" which would fit the German translation "-größe". But you are the experts in the field of l10n.

PS: Why is this thread resolved?
Comment 10 Julien Nabet 2016-01-16 18:05:02 UTC
(In reply to Heiko Tietze from comment #9)
> I would call it "size" which would fit the German translation "-größe". But
> you are the experts in the field of l10n.
> 
> PS: Why is this thread resolved?

It's solved for French translation part. The goal to ux-team is to know if English part (language from which all the translations are made) is ok. If yes, no pb, if no, perhaps we should open a brand new bugtracker about it.
Comment 11 Heiko Tietze 2016-01-16 18:16:43 UTC
(In reply to Julien Nabet from comment #10)
> ... if no, perhaps we should open a brand new bugtracker about it.

/done (thanks for reporting the issue)
Comment 12 Adolfo Jayme 2016-01-16 19:26:39 UTC
The English phrasing is now fixed as well (see bug 97192).
Comment 13 Tomaz Vajngerl 2016-01-16 19:42:32 UTC
In that dialog we have:

Original size: ...
View size: ... 
Image capacity: ... 
New capacity: ....

Renaming "capacity" to "size" will make things confusing. Better to explicitly state "File size", "New file size".
Comment 14 Adolfo Jayme 2016-01-17 08:32:25 UTC
I don’t think things are more confusing now than they were before, given that one can look at the values after the labels… the units make it clear that “size” refers to file size (kiB), and the explicit term “dimensions” IMHO helps to clarify the intended meaning of the word “size” even more. (By the way, why are the dimensions given in inches and pixels instead of centimeters and pixels?)

“Capacity” is too geeky, and imprecise (see comment 7).
Comment 15 Tomaz Vajngerl 2016-01-17 16:33:40 UTC
Ah OK sorry - I didn't see that you also renamed "Original size" and "View size" to dimension.

> (By the way, why are the dimensions given in inches and pixels instead of
> centimeters and pixels?)

Looks like it is a bug. This should depend on what locale you are using.